Showing results for 
Search instead for 
Do you mean 
Reply

Importing step files

I had a problem importing two step files which were made with Catia. They were opened with only sheet bodies inside them and I can't sew them to make a solid body, there are about 5000 sheet bodies. I have tried without success by increasing tolerance (maybe I do it wrong), healing geometry and optimizing it. If I examine geometry checking sheet boundaries I can see a lot of strange not connected sheets, it is a lot of manual work to repair it and I am not sure if I will success at the end. I know that the step files can be opened like a solid body because Inventor opened both properly and Solidedge did the same for one of them, so I would like to know why this problem is happening with NX and if I can use other  "automatic" method to have the solid body. For this two I have exported from Inventor the parasolid files and opened successfully as solid bodies with NX but I won't allways had the chance to use Inventor and I need to learn how to solve it with NX for future imporations. Thanks in advance.

3 REPLIES

Re: Importing step files

In the Import STEP dialog, in the Options group, turn On 'Swe Surfaces Automatically, SImplify and Optimize.

 

This will sew the surfaces on import assuming the surface edges are within the default tolerance (0.0254).

 

You can change the value of the tolerance to a larger number by finding the step203ug.def file and opening it for edit.

 

Find the 0.0254 value and set it to a larger number. Then save the file.

 

Not all CAD systems are as accurate as NX, so NX will seem 'picky' to newer users.

Re: Importing step files

Thank you RonY, I have tried editing options and tolerance without success. I am starting to think that the problem is with the step translator because it opens the part with some cylindrical surfaces that are not part or the actual part. Besides, once I open it with Inventor, I save in parasolid and step. NX open parasolid as a solid but not step.

Re: Importing step files

Be aware that Catia surface modeling does not consume bodies but creates a new body with each operation. If the wrong option is used on creating the STEP file there could be a lot of duplicate surfaces in the data which will confuse any mass sew operations. Try the Check VDA 4955 Compliance command for Identical faces.

 

 

Steve V