Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

NX Attribute Error While Trying to Edit An Attribute

Has anyone else seen this error before and if so, what does it mean and how do I enable this attribute to be edited?

 

 

Michael Pinto | Designer
NX11|Windows 10 Enterprise 64bit|HP Z-Book Studio G3 Workstation|Intel XEON E3-1505M|32GB Ram|Nvidia Quadro M1000m w/4GB
5 REPLIES
Solution
Solution
Accepted by topic author nikemike
‎07-11-2016 10:36 AM

Re: NX Attribute Error While Trying to Edit An Attribute

Ok I think I found out why I couldn't edit this attribute.

In the "Component Properties Dialogue"--> "Attribute" tab, On the "Apply To" section of the attribute tab, the "REFERENCE_COMPONENT" attribute was applied  to the "Part" and not on the "Instance" level. This is a component that is in the assembly. I wanted the component to be reference only in this particular assembly and not all assemblies.

After going through the NX help documents I found the area where the different "Apply To" options were described. I am just now starting to learn about Attributes and how to apply them. I still have much to learn in this area. Smiley Frustrated

Michael Pinto | Designer
NX11|Windows 10 Enterprise 64bit|HP Z-Book Studio G3 Workstation|Intel XEON E3-1505M|32GB Ram|Nvidia Quadro M1000m w/4GB

Re: NX Attribute Error While Trying to Edit An Attribute

Hello @nikemike,

 

I know there was some more info in our solutions center about this. What I did not remember, was that I wrote the FAQ myself Smiley Embarassed

 

Have a look here:

http://solutions.industrysoftware.automation.siemens.com/view.php?si=001-1993726

 

and also the explaination you gave could be found here:

http://solutions.industrysoftware.automation.siemens.com/view.php?si=001-1983071

 

Kind regards,

 

Dennis

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: NX Attribute Error While Trying to Edit An Attribute

Hello DennisdeBrouwer

 

I am new user in this forum.I have problem in create "Material" attributes in NX 9. I try to create new attributes " material" in attributes properties, but when i click BOM in Mold wizard, the material data data did not display in BOM. what should i do?

 

 

thanks for the answer

Re: NX Attribute Error While Trying to Edit An Attribute

Hello @agung_galih,

Sorry, I'm no Mold wizard expert, I had a quick look, but cannot give you the answer right away, maybe one of the others here, might be able to help you?

Kind regards,

Dennis
Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: NX Attribute Error While Trying to Edit An Attribute

I try to jump in here...

 

Moldwizard uses the standard Parts List functionality, but with a pre-defined Parts List format defined in the TOP part. I assume you did not change this fundamentally.

In this case, you also need to fill the DESCRIPTION Attribute or the CATALOG Attribute of the part with an unique value. Those two attributes are defined as so-called "key-fields". Key fields are basically a means for packing/unpacking rows. A row is packed if key-fields are matching, and the Moldwizard BOM Dialog only shows unpacked rows.

Documentation link

 

Regards, Johannes

Johannes