Reply

Sketches showing up

Since moving to ST7, I keep getting sketches showing up in the drafting view. This is likly a switch that has changed stated durring the upgrade.

 

What is the easiest switch to default sketches in draft to off? (sketches from model files)

 

Sometimes they are needed. In thoes casses I would expect to find the sketch in the parts list and turn it on, but in general. I don't use sketches from the models durring drafting.

10 REPLIES

Re: Sketches showing up

Hello 12GAGE,

 

I am not able to reproduce your issue.  I created both an ordered and a synchronous block, then placed a sketch on each.  I then made drawings of them.  The sketches do not appear unless you click no the view and choose properties, then go to the Display tab and show the sketch.

 

Can you provide a workflow that demonstrates the problem?

 

Steve

 

* Opinions are my own.

Steven Sheldon
Advanced Applications Engineer
Siemens PLM Software

* Opinions expressed are my own.

Re: Sketches showing up

Attache is a vid showing how I turn off the sketches now. On larger frame this is a pain.

 

I believ it has something to do with Derive "Display as Referance" but I don't know what that is saying.

(view in My Videos)

Re: Sketches showing up

In case my vid does not ever show up (most of the time) 

 

This is typically an issues with Frames. An assembly sketch is required as the wireframe for the structural ANSI shapes. I work in ordered.

Re: Sketches showing up

Hi 12GAGE:

 

It appears that you are recording your video only recording the document window - this makes it hard to see what commands you are selecting.  Can you record the full application?

 

Also, it appears you are turning off frame centerlines.  Is the issue with frame centerlines or sketches?

 

Thanks,

 

Steve

 

* Opinions are my own.

Steven Sheldon
Advanced Applications Engineer
Siemens PLM Software

* Opinions expressed are my own.

Re: Sketches showing up

yes. 

 

I do not want the centerlines of frame members showing up in draft by default. Is there a swtich for that? My goal is to avoid manually turning each one off in every view after the view is put into draft.

 

 

Re: Sketches showing up

[ Edited ]

12Gage, you are on the right track.

 

There are new additions in ST7 to this and the defaults can get changed up.

 

When you are placing a view, go in under the View Wizard here:

 

 

 

With the view wizard open, you see the .cfg,model view, zone dropdown like this:

 

 

With the selection as 'default, Solid Edge', the assembly display will drive what is shown and will also update based on changes you make. 'No Selection' is what you want. If you have already placed a view and need to fix it, right click the view, hit Properties, and look at the bottom of the screen on the Display tab. Here you again see the view dropdown, and you can see that there is a Check button and a Match checkbox, which are further ways of driving display off the assembly. Change the dropdown selection to No Selection and you'll 'unlink' the view. You are then allowed to edit the display options, and the extra stuff greys out. See here:

 

 

 

 

 

 

By the way, this took me forever to figure out what the hell I was doing differently to screw up my drawing views compared to ST6!

-Dylan Gondyke

Re: Sketches showing up

I have avoided using configurations to this point. I tried to look up the help on it, and could not access the on-line version of help (as is typical, just like my vid not showing up)

 

So now I need to ask about the configurations.

1. Can I get everything to operate from the configurations?

Like what shows up in views, Calculated weight, What shows up in the BOM, etc....

 

If there is a way to turn parts on and off the controls everything, I will use it frequently.

To avoid the issues, I copy the assembly, and delete the parts not needed.

 

Also, If I was 100% sure turning something off in the configuration would make it go away completely, then I could start my models with the new 3D box command, build my models around that, and turn the box off, rather than using planes. That would allow me to use family of parts.

 

Re: Sketches showing up


12GAGE wrote: ...I tried to look up the help on it, and could not access the on-line version of help  

Please note there was a technical issue with our online help server yesterday which has since been resolved.

Re: Sketches showing up

Hi 12GAGE:

 

I spoke with the product manager and he said this can be turned off by doing the following:

 

Uncheck the "Show tube centerlines" option under Solid Edge OPtions -> Annotation.

 

I have not tried this myself this morning so please try this and let me know if it works for you.

 

Steve

 

* My opinions are my own.

 

Steven Sheldon
Advanced Applications Engineer
Siemens PLM Software

* Opinions expressed are my own.