Cancel
Showing results for 
Search instead for 
Did you mean: 

Flowing backward warning is occurring in 'hydraulic pressurized tank' component

Pioneer
Pioneer

 

 

I'm using 'hydraulic pressurized tank' component in my hydraulic system model

 

03.jpg

 

Sometimes, 'Flow rate at port 2 is negative' warning message has popped up

 

01.jpg

 

 

Actually, flow rate at port 2 is positive, not negative

 

 

 

 

02.jpg

 

 

Well, even if a warning has popped up,
Check the 'Continuation run' option in 'Run parameter' and redo the simulation,
Simulation is working again.

 

This warning message appeared frequently.

I don't know why this error occurred

and, How can I handle it

 

Is it some kind of bug? in LMS Amesim?

 

 

 

 

4 REPLIES

Re: Flowing backward warning is occurring in 'hydraulic pressurized tank' component

Siemens Genius Siemens Genius
Siemens Genius

Hi @Kuro

 

can you try to activate the "discontinuities printout" option in the run parameters and start a new simulation?

 

2016-08-09 12_42_36-Run Parameters.png

 

Then when the error occurs, can you update your plot?

This would allow to add missing points showing us what happens.

Re: Flowing backward warning is occurring in 'hydraulic pressurized tank' component

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

Hi Kuro,

To prevent from possible negative flows at the tank intlet, just put a check-valve at the inlet.

 

 

tank.jpg

Re: Flowing backward warning is occurring in 'hydraulic pressurized tank' component

Siemens Experimenter Siemens Experimenter
Siemens Experimenter
Hi Kuro,

Another thing to check is your initialization values. This warning can also show up when initializations are not correct.
Brian Benoy, 1-D Application Engineer, Siemens PLM Software


Production: Amesim 14.1, Autonomie R12

Re: Flowing backward warning is occurring in 'hydraulic pressurized tank' component

Pioneer
Pioneer

Hi Domi

 

I activate the 'discontinuities printout' option and set 'print interval' vale to 0.001
but, I can not find missing point Smiley Sad

 

 

05.jpg

figure. activate the 'discontinuities printout' option

 

 

 

 

Hi LionelB

 

Following your advice, I added a check-valve component

After that 'Flow rate is negative' error is not occuring
But a new error -'Tank is empty'- is occuring, even if the tank is not empty Smiley Sad

 

 

 

 

Hi bbenoy

Ok , I'll check the initialization values of my system model, thx