Showing results for 
Search instead for 
Do you mean 
Reply

API causes crash

I've just started trying to use the API to output data from my models. I've written a script that outputs element centroid and strain data to the data table. The script seems to work, but every 5th to 10th time I run it, FEMAP crashes. Is there something obviously wrong with the script?

2 REPLIES

Re: API causes crash

Hello,

 

I can launch your script 20 times without FEMAP crashing. Appart from minor revisions/cleaning it is fine.

 

Check your run: something which can occur and which can cause FEMAP to crash is numbers with strange formats (too big or too small). The FEMAP team has increased robustness in later versions, but depending on the version you're using this could be the problem.

 

If you go To "Post Data" (the { } button), select your output set and vector, click on "Vector Info", FEMAP tells you the min and max values. If something like "1.#INF#"  appears this is a value in your output file (op2?) that FEMAP was not able to deal with, this has caused crashes for us in the past.

 

AP

Re: API causes crash

Thanks for the reply.

I investigated the extremes of my vector results, and they don't seem to have that problem.

I had been working with attached results--not ones that had been directly loaded into the database. Friday I loaded the results in, and that seemed to alleviate the problem.

One other thing foible with this script, though: once in a while, it seems to just stop posting info to the data table. After I run it, it gives me the message that the data table is empty. I look at the 'Show/Hide Columns' button in the data table, and it looks like it's loaded all the correct column headings, it just doesn't put any data there. The only way I've found to fix it is to restart FEMAP. Any ideas on that issue?