Cancel
Showing results for 
Search instead for 
Did you mean: 

APIs don't work without older Femap version installed

Creator
Creator

Strange issue. Just got a new CPU. Old CPU had the last 4 or so versions of Femap installed on it. APIs worked fine in v11.2.1 on that machine

 

At one point, I had tried uninstalling the old versions and leaving just v11.2.1. But then the APIs stopped working (API Error, Line XX: Expecting a valid data type). Reinstalled the old versions and everything was working fine again

 

Now I'm on a new CPU, with just v11.2.1 installed. But same issue. None of the APIs work, and they all give that "valid data type" error

 

Thoughts? Besides installing a bunch of old versions of Femap?

Thanks

2 REPLIES

Re: APIs don't work without older Femap version installed

Siemens Phenom Siemens Phenom
Siemens Phenom

Was v11.2.1 "installed" or just copied to the machine?   It needs to be installed to get all of the OLE/COM objects properly registered.

 

If it was installed properly, can you send a small sample API that fails.... more specifically, you say the error is "API Error, Line XX: Expecting a valid data type".... what is the code on Line XX?  and how is everything defined for that line?

 

Are you running in the FEMAP Basic environment? or outside FEMAP in something like Visual Basic?

 

Re: APIs don't work without older Femap version installed

Creator
Creator

It was a copy. Installing the program fixed the APIs. Thanks for the insight