Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Alt+Tab improvement request

[ Edited ]

When a FEMAP dialog is open (e.g. when first creating a data surface; this also applies to any dialog being open), alt+tab doesn't work to switch back to FEMAP from another program in Windows 7. This is really annoying when I've got Excel data that I'm pasting into FEMAP.

 

Also, when alt+tabbing away from FEMAP w/ open dialog, the behavior is nonstandard (i.e. it skips an index in the queue of open programs).

 

Can this please be improved? Thanks!

12 REPLIES

Re: Alt+Tab improvement request

Could you describe in a little more detail exactly what you are doing (what programs, what key sequences, ...) and what you are seeing that is wrong?  It seems to work fine for me on Windows 7 with the scenarios I have tried.

 

Do you have any other programs installed and running that capture key sequences, Windows messages, the screen, etc.?

Re: Alt+Tab improvement request

The dialog below, for example. You open it in the data surface editor, and once it's open, you can't alt+tab back to FEMAP, which no longer appears in the alt+tab list of programs.

 

dialogerr.png

This is what I see when I alt+tab around with this dialog open:

attab_nofemap.png

Re: Alt+Tab improvement request

Unfortunately we can not reproduce the behavior you are seeing and have not heard of this problem before.  To clarify... is it just this dialog that you show, just dialogs from the Data Surface Editor... or any dialog, in any FEMAP command?

 

Exactly what version of Windows are you running (from Control Panel->System and Security->System)?

 

Do you have any other keyboard, screen grab or "helper" type programs installed?

 

Do you see the same behavior if you use the "Windows Key"+Tab instead of Alt+Tab?

 

 

Re: Alt+Tab improvement request

It seems to be intermittent actually. I only noticed it when it failed, and assumed it happened all the time. If I find a reproduceable set of steps I will post them. Thanks!

Re: Alt+Tab improvement request

Ok I have a path that always produces this error now.

  1. Open FEMAP (a new empty model will be created).
  2. Right-click on boundary conditions and select New.
  3. With the new boundary set dialog open (and cursor blinking in title field) Alt+Tab away from FEMAP.
  4. Note that you cannot Alt-Tab back to it, as FEMAP no longer appears in the list of open applications.
  5. Windows+Tab works.

 

Re: Alt+Tab improvement request

Sorry to say I still can not reproduce your problem... even following the workflow you describe. 

 

What program do you tab into and do you do anything specific there or just tab back?

 

Exactly what version of Windows are you running (from Control Panel->System and Security->System)?

 

Do you have any other keyboard, screen grab or "helper" type programs installed?

 

What other FEMAP panes do you have open (maybe just send a screenshot)

 

Can you send me your FEMAP.INI file so I can see if we have any Preference differences (you can find the location of the .INI file in the list in Help->About)

Re: Alt+Tab improvement request

I'm using Windows 7 Entrerprise SP1.

I don't have any keygrabbers installed but it wouldn't surprise me if there was one. No other applications do this though.

 

It seems like any dialog in which the focus is in a text field (and possibly an element selection field) exhibits this behavior.

 

When I alt+tab away I can't even shift+alt+tab back. I have to find FEMAP in the taskbar and click on it to bring it forward.

Solution
Solution
Accepted by topic author Kava
‎02-01-2017 05:15 AM

Re: Alt+Tab improvement request

Dear Kava,

I run Windows 10  Pro x64 with FEMAP V11.3.2 and I can report that ALT+TAB is running forward and backward OK in my computer, here you are the proof:

alt-tab-running-ok.png

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Alt+Tab improvement request

Are you using a screen capture program such as SnagIt or similar?

 

These programs tend to take over other applications key bindings...

Best Regards,
Chip Fricke
Principal Applications Engineer - Femap Product Development