cancel
Showing results for 
Search instead for 
Did you mean: 

Astroid really slow rotation with Femap 11.3.2.

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

I use a Spatial Freedom Astroid 3D controller to rotate, zoom, and pan the models on the screen.  So far with all previous versions of Femap fom 10.3 to 11.3.1 the Astroid has worked very well.  I installed 11.3.2 this morning and have discovered that the models rotate, zoom, and pan extremely slowly when using the Astroid.  It is like dragging the models through treacle!  Sooner or later I am going rip the knob off the Astroid!  If I open Solid Edge or any earlier version of Femap all is good but 11.3.2 doesn’t work so well.  It has to be a problem with 11.3.2.  Anybody have this problem?

6 REPLIES

Re: Astroid really slow rotation with Femap 11.3.2.

Siemens Phenom Siemens Phenom
Siemens Phenom
Check your Spaceball Preferences for the Translation and Rotation Scale Factors. In addition, turn on the option for Print Debug Messages.
Best Regards,
Chip Fricke
Principal Applications Engineer - Femap Product Development

Re: Astroid really slow rotation with Femap 11.3.2.

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

Hi Chip,

 

Spaceball preferences are stock standard and the same as all previous installations I have run.  All scale factors are set to 1.0.  I did try some larger numbers but it made no difference.  I turned on Print Debug Messages.  What am I looking for there?  Presumably some large millisecond numbers?  Because if so, the numbers do not differ much if at all from earlier versions of Femap.  I also looked at the frames per second and these also do not differ from earlier versions of Femap.  It's like the actual speed of rotation, zooming, and panning has just been slowed right down.  Also, something else I have noticed is that the model will not rotate while you are zooming or panning.  It will only rotate when you let off zooming or panning.  Makes for quite jerky motion if you are trying to look at at a detail or something.

Re: Astroid really slow rotation with Femap 11.3.2.

Siemens Phenom Siemens Phenom
Siemens Phenom

What OS, Graphics Card and Driver are you using?   If possible, a screen shot of the Help > About dialog box.

 

2016-11-14_18-20-44.jpg

 

In addition, can grab a screen shot of your Femap Preferences, Graphics tab?

 

It looks like the latest driver for the Astroid is A063-111-361:1.  Since I don't have an Astroid device available, I have no way to test this myself.

 

Best Regards,
Chip Fricke
Principal Applications Engineer - Femap Product Development

Re: Astroid really slow rotation with Femap 11.3.2.

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

OS is Windows 7 Professional Srvice Pack 1.

Graphics Card is NVIDIA Quadro 4000.

NVIDIA Graphics Driver version is 10.18.13.5442.

 

I have the latest Astroid Driver as per the web page spatialfreedom.com.  That version is 2.16.

 

Refer attached screen shots of Femap About Box and Preferences.

 

Re: Astroid really slow rotation with Femap 11.3.2.

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

Chris,

 

In 11.3.2, we changed the rotation code for the Astroid so it can do all the rotate about different centers that was available to mouse users. In doing so, we had to change the way we handle the Astroid messages. The new way is now controlled by the /File/Preferences... and select the spaceball tab - if you set all the values to about 10, you should be close to the speed in 11.3.1 and before. The default settings give a complete revolution in under 1 second. The numbers in the preferences should scale linearly.

 

Bill

Femap Development

Re: Astroid really slow rotation with Femap 11.3.2.

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

Bill,

 

That worked.  I changed all the Spaceball translation and rotation parameters from 1 to 10.  I also pulled the Directional Sensitivity slider all the way left to Allow All and that stopped the model from being so spastic when being rotated while panning and / or zooming.

 

Cheers,

 

Chris