Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Bug - Unable to extrude solid beyond 500

[ Edited ]

I ran into an interesting issue today.  When I try to create a solid extrusion longer than 500, it doesn't work, it just creates a curve at the extent step.  I'm on 11.2.1. 

 

1) Create a boundary surface

Capture.PNG

 

2) Create a solid extrusion to depth 500

Capture1.PNG

 

3) Extrusion worked as expectedCapture2.PNG

 

4) Undo previous command and now create the extrusion to 501Capture3.PNG

 

5) Creates a circle at 501, no extrusionCapture4.PNG

 

 

Am I doing something wrong, or is this a bug in the software?

 

4 REPLIES
Solution
Solution
Accepted by topic author ajostler
‎06-24-2016 01:37 PM

Re: Bug - Unable to extrude solid beyond 500

Parasolid works in a "box" that +/ 500 in X, Y, and Z.  It does this so that all operations are done to a particular tolerance.  In Section 2.6.2.7 of the FEMAP Commands manual, there's a brief write up on this.  In short, if you are going to work outside the +/- 500 box, I would go to File - Prefereces, pick the Geometry/Model tab, and change the Solid Geometry scale factor to something higher.  There's default settings of 39.37 (maintains the internal Parasolid in meters, but displays in inches), making the box effective +/- 20000.0, and Millimeters, scale factor of 1000.0, again internally the model will be in meters, but everything you do in FEMAP will be in Millimeters.  There's also an option to make it whatever you want.  I'd recommend on of the two standards, it's the way most CAD systems handle Parasolid, storing everything internally in meters.

 

Whenever you mess with the Geometry Scale Factor, I would stop and restart FEMAP and then do everything with the new scale factor.  You can get quite a mess going if the solids in your model are internally all different scale factors.  If you ever get in this situation, you can use Geometry - Solid - Cleanup, and there's an option there to make everything consistent with the current model scale factor.

Solution
Solution
Accepted by topic author ajostler
‎06-24-2016 01:37 PM

Re: Bug - Unable to extrude solid beyond 500

Hello!,

This is not a bug at all, in my system runs OK, this a current limitation of Parasolid, Chip Fricke explained very well in this presentation:
http://www.iberisa.com/transfer/Geometry_Import_and_Preperation_for_Meshing_in_Femap.zip

 

In my FEMAP V11.3 under FILE > PREFERENCES > GEOMETRY/MODEL I use a "Solid Geometry Scale Factor = mm", ie, "geometry scale factor = 1000"; this means that 500 units for me are 500 mm  (an stored internally in the database as 0.5 metrs). But if you set this parameters to meters, then 500 length units in FEMAP are 500 meters, and you reach the Parasolid limitation, all is written in the following two slides (download the ZIP file, is very interesting!!):

 

parasolid-geometry-kernel1.png

parasolid-geometry-kernel2.png

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Bug - Unable to extrude solid beyond 500

Thanks for the great responses! I wasn't aware of that limitation in parasolids.  

 

I had never switched the scale factor before. I always just stay consistent with my units, and I usually work in meters, so I hadn't run into this issue before.  Is it important to switch the scale factor when I'm using different units besides, or is it okay to keep it in meters, and just know that I will possibly run into the limits of the parasolid "box"?

Re: Bug - Unable to extrude solid beyond 500

Hello!,

If you work in machinery FE models with relatively small dimensions where stress & pressure units are in MPa then I strongly suggest to set the Geometry Scale Factor = mm (ie, 1000) and enter always length units in millimeters, apply forces in N, and define density in Tons/mm3 (also please note MASS is in Tons). Also, you need to define your material properties EX in MPa, etc..

But if your product is vessels, or ships with big lengths, then working in meters could be reasonable. In this case locate the CENTER of your vessel in the (0,0,0) coordinate system to avoid the Parasolid limitation, OK?.

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/