cancel
Showing results for 
Search instead for 
Did you mean: 

FEMAP and INCLUDE statements

Pioneer
Pioneer

Hi

Does anyone know of a solution to the problem in FEMAP which prevents include statements greater than 72 characters being "preserved"?

 

I have the following include statements in my *.dat file.

include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt1_IF.dat'
include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt2_IF.dat'
include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt3_IF.dat'

include '..\..\..\
        02_Components\07_Lockdown Bkt\ver1\Lockdown_Bkt1_IF.dat'
include '..\..\..\
        02_Components\07_Lockdown Bkt\ver1\Lockdown_Bkt2_IF.dat'
include '..\..\..\
        02_Components\07_Lockdown Bkt\ver1\Lockdown_Bkt3_IF.dat'

 and when I import the deck into FEMAP with the "preserve INCLUDE statements" active, and then export th e analysis, I get

 

include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt1_IF.dat'
include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt2_IF.dat'
include '..\..\..\02_Components\06_Latch Bkt\ver1\Latch_Bkt3_IF.dat'
include '..\..\..\
include '..\..\..\
include '..\..\..\

In addition, if I have an include statement in the CASE CONTROL section eg XYPLOT data, the include statement is moved to the bulk data section on export.

 

I am aware I can edit the preview, but that is not how the program should be functioning.

 

I am using FEMAP 11.2.0

 

Thanks

Peter

 

1 REPLY

Re: FEMAP and INCLUDE statements

Siemens Phenom Siemens Phenom
Siemens Phenom

Peter,

The issue with import processing of the long include statements when "preserve include" is checked has been identified and we believe it has been corrected for the next release. 

 

The only workaround I can suggest is instead of using "edit preview" which is a dynamic edit and goes away after submitting, to actually correct the include statements in the "start text" or "end text" where the incorrect statement is stored as part of the analysis set. Now your correction is stored for future submits.

 

Instead of importing these problematic file names, you can also create them directly by using "start text" or "end text" on the bulk data form and create the correct include statements using the "text from file" option. See below:

2017-02-23 11_09_16-Femap with NX Nastran - [Model1] - [Untitled].png

 

Regards,

 

Joe