Showing results for 
Search instead for 
Do you mean 
Reply

Graphics performance in post processing

Hi,

 

I am using a dual xeon (I think it is a dual xeon 2609 but not sure if thats the exact model) with an Nvidia quadro K4000.

While manipulating models with high element count and for example with model data contour for elemet quality turned on, the program gets stuck for quite a while when trying to rotate and zoom in and out.

I installed a small app that says what resources are being used, and the GPU is not used almost at all (20% max) in such opertaions, while the one of the CPUs gets 100% and the other CPU is also not used. How can I tell Femap to use more CPUs and GPU power in such opertations concerning graphic manipulation of models?

 

Thanks. 

4 REPLIES

Re: Graphics performance in post processing

Dear Assafwei,

One of the new GREAT features of FEMAP V11.X series was the VERTEX BUFFER OBJECTS (VBO) technology. Graphics performance now in new FEMAP V11.1 is improved through more efficient graphics storage and added support of OpenGL® geometry shader functionality. Femap 11.1 can take advantage of OpenGL 4.2 (and above) graphics, which are much faster and use significantly less graphics memory.

To take advance of this technology (you need to have a modern graphics card with 2 GB RAM Video) simply activate it under "FILE > PREFERENCES > GRAPHICS > GRAPHICS OPTIONS > VERTEX BUFFER OBJECTS".

 

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Graphics performance in post processing

Hi Blas,

 

VBO is activated, and still, the CPU is working harder than the GPU, and performance is not so good. Any way to make the GPU work harder, or to make the two CPUs work rather then only one CPU?

 

Thanks.

Re: Graphics performance in post processing

Then check your options under PREFERENCES > GRAPHICS compared with mine. In my FEMAP V11.1 I am able to rotate very big models quite fast, not problem, and I run a nVIDIA K3000 with 2 GB RAM in a laptop computer.

 

Also, very important: in FEMAP go to "HELP > ABOUT" and make sure you see "OpenGL vendor = NVIDIA CORPORATION". If not, you don't have configured the NVIDIA as your preferred graphics engine.

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Graphics performance in post processing

OK I will try.

 

Thanks.