Cancel
Showing results for 
Search instead for 
Did you mean: 

Help - Excessive Pivot Ratio Error

Experimenter
Experimenter

Hi,

 

I have been attempting to create a plate element model of a bucket wheel reclaimer.

 

In order to create this model, I modelled half of the reclaimer in Autodesk Inventor, imported it into FEMAP, midsurfaced the model, tidied the geometry, meshed and ran a linear static analysis on the model with purely a self-weight load. After I was confident the “half” model was correct I mirrored the model, constrained it and tried to run the model again with a self-weight load but I get an error due to “excessive pivot ratios”.

 

As excessive pivot ratios are generally a result of the model not being correctly constrained I looked at the deflections in the model it appears as though the model isn’t joined along the “mirror plane”.

 

In order to fix this issue I tried merging coincident nodes to ensure the mesh was joined, checking to ensure no free edges existed in the model, checking the mesh quality in case there were corrupted elements and checking the elements to ensure they all had properties.

 

Beyond this I tried the following 2 fixes, but got results I didn’t understand and as such have two questions:

 

  1. Merge coincident points to ensure geometry was joined:

In trying this FEMAP stated that there were a number of non-megeable points within the tolerance specified (less than 1mm apart). What stops FEMAP merging points? I can’t understand why FEMAP wouldn’t alter the geometry to suit.

  1. Re-associated elements with geometry

In trying this FEMAP was unable to associate a number of elements to solids. I don’t understand why this would be the case as the minimal mesh manipulation was used.

 

Could anybody provide any clarity on the above points or provide any advice as to what else might be causing the excessive pivot ratio errors I am getting.

 

Any help would be greatly appreciated.

 

 

 


Regards,

Craig  

5 REPLIES

Re: Help - Excessive Pivot Ratio Error

Legend
Legend

Hi,

 

you don't need to merge coincident points.

 

Maybe you used in first analysis symmetry constraint. In this case the output coordinate system of nodes in symmetry constraint had a local coordinate system. Then use Modify > Update other > Output CSys command, and set output coordinate system of all nodes to 0..Basic Rectangular before merging nodes. Or you can use checkbox "Merge Across Output CSys" in Check Coincident Nodes command.

 

Maybe you didn't select all nodes in your symmetry plane by merging (nodes in nonvisible layer...). In this case you can select nodes with "on Element" method in Entity Selection dialog box by Check Coincident Nodes command (or modify layer of this nodes).

 

When this not help you, please attache your model.

 

Best regards,

 

Peter Kaderasz

Re: Help - Excessive Pivot Ratio Error

Legend
Legend

The best remedy to detect the max pivot ratio error source is to run a FREE-FREE analysis.
It consists in a normal mode analysis of your model. No constraints/loads should be defined. and you could ask for 20 modes for example.

 

If no mechanisms are authorized in you system then you should have 6 rigid body motions (equal or near to 0Hz).


When you activate the animated view and go from eigenmode to another you will see which parts are not connected to the rest of the structure.

 

If your model parts are well connected then make a test by directly applying the boundary conditions to nodes instead of geometry.

 

What stops FEMAP merging points?

- Nodes defined in different output coordinate system. You can define the same csys for all nodes under Modify/UpdateOther/OutputCsys.

 

- Prevent elements corruption (are you using RBE elements?)

 

 

Otherwise if you could put your modfem / neutral here we will take a look at it.

 

 

Seifeddine Naffoussi

Re: Help - Excessive Pivot Ratio Error

PLM World Member Legend PLM World Member Legend
PLM World Member Legend

You might have some superflous nodes floating around.  Try selecting all the nodes and deleting them.  Only the unattached nodes will be deleted.

Re: Help - Excessive Pivot Ratio Error

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

When you mirrored the half model then FEMAP create a new local coordinate system that is assigned automatically to the new created nodes: this prevent to merge nodes, then the error of free rigid modes. Simply use command MODIFY > UPDATE OTHER > OUTPUT CSYS and assign to ALL nodes the global cartesian 0..BASYC RECTANGULAR, next use FILE>REBUILD, then delete all coordinate system, and next merge nodes, you will see that now you are success!!.

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Help - Excessive Pivot Ratio Error

Experimenter
Experimenter

Thanks for the help guys.

 

Tried deleting all superfluous nodes, then selected all nodes and aligned them to the same coordinate system and finally merged all coincident nodes and the model ran perfectly. 

 

Thanks again.