Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Merging models scales geometry but not mesh

L.S.,

 

I have a strange issue when merging two models in FEMAP v11.3.

For both models the solid geometry scale factor is set to meters. The diameter in both seperate models is the sam and there are no overlaps in numbering, which can cause this issue.

 

When merging, the mesh from the "from model" merges with the correct scale factor, ie it connects to the "to model" correctly, but the geometry is scaled up by a factor of 25.4 (coincidentally the inch scale factor?).

I have attached 2 pictures which show the geometry and the mesh after the merge process.

 

What can I do to fix or prevent this issue?

 

Regards,

Gertjan

4 REPLIES

Re: Merging models scales geometry but not mesh

Dear Gertjan,

It seems you have a configuration issue in FILE > PREFERENCES > GEOMETRY: check in your case that SOLID GEOMETRY SCALE FACTOR is set to "1..Meters".

FILE-PREFERENCES-scale-factor

Also list your geometry in both FEMAP models using command "LIST > GEOMETRY > SOLIDS > Select ALL" to check that the listing in the message area says "Address: xx Scale: 1", this way you can verify your geometry has the correct scale factor on it. If not, this means that the model was initialy created using the wrong Solid geometry scale factor, is a typical problem to forgot to setup correctly under PREFERENCES after installation of a new FEMAP release, OK?.

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Merging models scales geometry but not mesh

Hello!,
I forgot to tell you: when you have a model containing geometry in more than one scale factor use command GEOMETRY > SOLID > CLEANUP, this command will adjust the internal scale factor of each piece of selected geometry to match the Solid Geometry Scale Factor that is currently set in File, Preferences on the Geometry/Model tab.

Do not use the option REMOVE REDUNDANT GEOMETRY if you have imprinted curves or performed some of the matching commands since imprinted curves are considered extraneous and will be removed. Redundant geometry is geometry that is not required to define the volume of the solid. Examples of this could be curves that have been imprinted in a face to split it into regions, points used to split curves, or multiple surfaces that are all really part of the same underlying geometric surface.

solid-cleanup-match-model-scale-factor.png

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Merging models scales geometry but not mesh

Hello Blas,

 

Thanks for the quick answer.

The solid geometry scale factor is set to 1..Meters for both models.

 

However it seems that indeed there is a discrepancy between scale factors on my geometry, 39.37 in my model and 1000 in the base model. However the base model (v2) is created from a previous model (v1) in which the scale factor of the geometry is in fact 39.37. To create the v2 model a geometry from CATIA has been imported into the v1 model which subsequently changed the scale factor to 1000.

 

So my question now is how can I manually change this scale factor when I merge the two models?

 

Regards,

Gertjan

Solution
Solution
Accepted by topic author Ingenieur81
‎09-06-2016 05:21 AM

Re: Merging models scales geometry but not mesh

Dear Gertjan,

As explained above before using MERGE command simply open your FEA models in FEMAP and one-by-one use command "GEOMETRY > SOLID > CLEANUP >Select ALL" activating as minimum the option MATCH Model SCALE FACTOR and you are done!. Later when using the command FILE > MERGE you will see that the geometry is scaled correctly.

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/