Cancel
Showing results for 
Search instead for 
Did you mean: 

Midsurface appears shifted with respect to the original solid

Pioneer
Pioneer

I am trying to create midsurfaces of a solid which is part of an assembly.

The procedure I follow is this one:

 

geometry --> midsurface --> automatic

Then I select the solid, set the target thickness and check the box "pre-v11.1 Midsurface method"

 

The problem arises here, infact the surfaces do not appear at the same location of the solid, instead they get shifted to another part of the screen and they are also made much smaller than  the original solid (see picture). It happens every time I try to create a midsurface (even if I tahe another solid into accout) and Femap always places them close to the grey dot, no matter the original position of the solid. (The solid I used to generate those surfaces is much bigger and far away from that point this is why I was not able to show it in the image, which is a magnification to let you see what happened)

 

How can I solve this problem?

 

Thank you in advance

midsurface.png

6 REPLIES

Re: Midsurface appears shifted with respect to the original solid

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

This is a problem of "Model Scale Factor" that is not matching.

 

You have a model containing geometry in more than one scale factor. You need to adjust the geometry’s internal scale factor to the Solid Geometry Scale Factor that is currently set in "File > Preferences > Geometry/Model > Geometry Preferences":

 

preferences-geometry-scale_factor.png

 

I suggest to set the geometry escale factor correctly under preferences (either inches, milimeters or meters), exit FEMAP to save preferences, then open again, and then create a new model in FEMAP and now import the geometry (the assembly file) making sure that you are using the same geometry scale factor during import.

 

For instance, if "mm" defines under PREFERENCES, then when importing a geometry using "FILE > IMPORT > GEOMETRY" you will see by default the Geometry Scale Factor = 1000. Also set OFF "Increment Color", this way FEMAP do not modify randomly the color of edges curves from the assembly parts.

 

import-geometry-options.png

 

Another check to make always after importing any geometry in FEMAP is to use command "GOEMETRY > SOLID > CLEANUP", activating the FOUR options: this command will check the solid, and remove any extraneous features which are not part of the actual solid, but may have developed during export from a CAD package or from Boolean opera­tions on it. If a portion of your solid appears inaccurate, or drawn incorrectly, use this command to see if you can remove it.

 

solid-cleanup.png

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Midsurface appears shifted with respect to the original solid

Pioneer
Pioneer

Thank you for your fast reply. Just one more question: is there a way to change the scale factor without having to import the cad again? Because I have already meshed the other parts of the assembly and it took me nearly 2 weeks of work to do it. Beside, all the other parts did not show this problem.

Re: Midsurface appears shifted with respect to the original solid

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

You can use command "GEOMETRY > SOLID > CLEAN-UP" with the part that give you problems to try to solve the matching problem

 

Altermatively, you can import again the CAD assembly in a new layer, make that layer the ONLY VISIBLE (choose SHOW SELECTED ONLY) and delete the components that are not desired. Or go to your CAD and EXPORT only the part that give you problems, not the full assembly, and import in FEMAP again (you can delete the old one anytime later). In any case you must make sure to use the same GEOMETRY SCALE FACTOR that you have setup in FEMAP under FILE > PREFERENCES, OK?.

 

As you see, in FEMAP you can add any CAD component at any moment, you can import the full assembly at the beginning or add components at any time you need, FEMAP manage perfectly the geometry numbering: one thing is the CAD geometry and other the mesh!!.

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Midsurface appears shifted with respect to the original solid

Pioneer
Pioneer

Ok, I think I got it Smiley Happy

Now that I have been thinking about it I remember that when I first upload the CAD I accidentally used a scale factor which converted everything in inches. Then I converted the units again using the tool (tools --> convert units), but I did not change the preferences. Can this be the source of the error I got?

 

One last question, just to better understand the effects of this different scale factors on the analysis results. If I run a modal analysis of the model as it is now (so with the 2 scale factors and assuming I manage to mesh all of the solids somehow) how will this affect the analysis results?

 

Thank you again for your help

Regards

Re: Midsurface appears shifted with respect to the original solid

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

Well, FEMAP is dimensionless, then if you have defined your FE model (nodes, material properties, loads, etc..) in a coherent way (you have a coherency between units length, force, mass, density & material properties) so it will not be affected at all by the settings done in FILE > PREFERENCES > GEOMETRY > SOLID SCALE FACTOR. These setting only affect when you import a CAD geometry file, OK?. Make some tests in your model measuring distances to see that everything is correct.

 

In summary: is critical to define correctly the solid scale factor, (ie, choose millimeters, inches or meters) in FILE > PREFERENCES, but this setting only affect to the way of importing geometry.

 

If you enter a distance in FEMAP using a value of 100, for you this could be meters, km, miles, etc.. You are the ONLY responsible of the coherence of values used in your FE model, not FEMAP, ok?.

 

For instance, if you choose millimeters (mm) for length in FILE > PREFERENCES > GEOMETRY (ie, Solid Scale Factor = 1000), then a coherent system of units for Structural Static & Dynamic as well Heat Transfer Analysis is the following:

  • Force = Newtons
  • Pressure & Stress = MPa (ie, N/mm2)
  • Mass = Tons.
  • Density = Tons/mm3
  • Length = mm
  • G =  Mpa
  • nu = dimensionless
  • AlphaX (Thermal Expansion Coefficient) = mm/mm/degC
  • KX (Conductivity) = Watt/mm-degC
  • Cp (Specific Heat) = J/Tonne-degC
  • Stress Limits = Mpa.

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Midsurface appears shifted with respect to the original solid

Legend
Legend

Hi Olgola,

 

you can use  Modify / Associativity / Automatic... command to associate the earlier created mesh to the newly imported geometry.

 

Best regard

 

Peter Kaderasz