Showing results for 
Search instead for 
Do you mean 
Reply

PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Hello,

 

I thought FEMAP had improved the graphics performance in version 11 by implementing VBO support. I cannot notice this improvement in practice:

 

I'm working with a global ship model - approx 150 000 nodes and 290 000 elements - mostly plates. The full model geometry is also present in the model split into a few large solids.

 

The problem is - the model performs extremely slowly when it comes to graphic operations - rotating, zooming, selectiong elements etc.

 

My computer is a Lenovo W530 ThinkPad.

RAM:16 GB

Processor: Intel Core i7-3630QM 2.40 GHz

Graphics: NVIDIA Quadro K1000M

 

Is there any tricks for tweeking the perfomance or are some settings  terribly wrong by defult?? Or do I just need a more powerful computer?

 

-Kristoffer

 

16 REPLIES

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Dear Krisu,

Send a copy of the model to FEMAP developers because this is not a big model to have problems moving or rotating, I run a laptop as well with QUADRO K3000M and not problem rotating big models with millions of nodes, simply is a question of configuration using FILE > PREFERENCES > GRAPHICS and activating VERTEX BUFFER OBJECT.

 

Certainly a nVIDIA QUADRO 1000M is not very powerful because low RAM memory, but not too bad. Make sure you run the last version of FEMAP V11.1.2, and also go to HELP > ABOUT and test the OpenGL vendor is NVIDIA and version of OpenGL is minimum 4.2, in some laptops with Intel Graphics base cards you need to make sure under NVIDIA CONTROL PANEL that the NVIDIA card is the ONE selected for preferred graphics processor, OK?.

 

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Thank you Blas,

 

Ok, I trust that the following settings need to be changed in order to improve the perfomance. Thans for the advise!

 

-Kristoffer

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Kristoffer,

 

Is the performance ok with Performance Graphics turned on?  Please let us know.  If you require further assistance, please do not hesitate to contact me -

 

sherman dot mark at siemens dot com

 

Mark.

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Mark,

 

Yes, the graphic performance increased considerably

 

-Kristoffer

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

L.S.,

 

Can I hook into this topic to ask for similar advice for poor graphics performance on my model.

I have a large model of 850000 nodes and elements. I have the geometry (solids) of about a quarter of the model in there as well.

 

My workstation is a Dell Optiplex 3040 with:

Intel Core i5-6500 @3.2GHz

16Gb RAM

NVIDIA Quadro K620 graphics card

 

Help > About and Graphics Preferences are as follows.

About windowAbout windowGraphics preferences windowGraphics preferences window

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Turning Performance Graphics off or on does nothing to improve performance.

 

I did notice that the model rotates, zooms and pans smoothly when I select "Show Full Model". But when I select "Show Multiple Groups" and I show and hide several groups performance drops significantly, however when I select only 1 group (even a group of the full model) performance is good.

 

Can you suggest any settings to improve performance?

 

Regards,

Gertjan

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Gertjan,

 

I cannot quite read the NVIDIA driver version - is it 369.26?

 

Your machine is not a worksation but your CPU looks fast enough. I would expect more from a K620 as it is a relatively recent card. Are you able to send the model through GTAC - ask them to send the PR to Bill in Femap development. What OS are you using? What are the settings on your /File/Preferences... database tab?

 

One thing to try to get some more information is to switch on the debug messages to all, switch on the OpenGL errors and switch the VBO errors to all - these are on the preferences dialog you included in the Advanced/Debug section. Exit Femap and restart Femap and open your model. Rotate it a little and then save all the text that has been written to the message window by right mouse click - select all and then copy. Send this data with the model to GTAC.

 

Bill

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Hello Bill,

 

You are correct the driver version is 369.26.

I am using Windows 7 Enterprise 64-bit.

The settings on the Database tab are:

FEMAP_database_preferences.png

 

I will discuss with my supervisor if I am allowed to provide the model to you.

 

Regards,

Gertjan

 

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Gertjan,

 

Thanks for the database tab image - you have your limit set to 3261MB and you are only using a fraction of that for the in memory database (as indicated by the dark blue band). On your graphics tab image you sent in a previous email, it looks like you might have the max VBO MB set to 10240MB i.e. 10GB. You should never set this to more than the amount of memory your graphics card has and we normally advise setting it at about half what your graphics card has (possibly 3/4). Please try setting this to 1024MB and see if that helps.

 

Bill

Re: PROBLEM:SLOW GRAPHICAL PERFORMANCE WITH LAGE MODEL

Bill,

 

Thanks for the tips.

I set the max VBO MB to 1024, but I do not see an increase in performance.

 

Some additional information about the problem.

Zooming is fine at the moment and when the model starts rotating/panning that is also very smooth. It takes about 5 seconds after I start rotating/panning for the model to catch up and show the actual rotating/panning.

 

Regards,

Gertjan