Cancel
Showing results for 
Search instead for 
Did you mean: 

Problem with mesh control and editing

Creator
Creator

Hello.

I perform a nonlinear analysis of a curved circular tube.

I completed the preparation of the mesh with : Mesh control - size along curve.

When Femap generates a mesh, only 1 element is always generated along the tube thickness.

Even though I change the number of elements on the curves in the radial direction of the tube section.

 

01.JPG

02.JPG

When I use Meshing toolbox - Mesh sizing , the grid dimensions also do not change.

In my research, I need to perform analyzes with different sizes of the finite element grid.
Tell me which commands should I use here?

file below

Thanks

 

7 REPLIES

Re: Problem with mesh control and editing

Siemens Genius Siemens Genius
Siemens Genius

Try using the command Mesh > Editing > Edge Split 

 

Select a node on the outer wall of the tube and then select a node on the inner wall of the tube. You can specify the number of splits you would like. 

 

Before Split.JPGAfter Split.JPG

Re: Problem with mesh control and editing

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Dear Vadzim,

The reason of the meshing error is the underground geometry:

  • You have created two boundary surfaces using the two circles, wrong!!.  You need to select the two circles at the same time and create only ONE boundary surface.
  • Also, you have created isolated curves in the radial direction that are not connected with anything, then is useless to refine the mesh size there because the HEX mesh is not associated.
  • When working with BOUNDARY SURFACES the correct procedure is to convert the boundary surface in Parasolid surfaces using command GEOMETRY > SURFACE > CONVERT, the command will create a genuine surface and will delete the "original" boundary surfaces. Next use GEOMETRY > SOLID > EXTRUDE to generate the solid body to mesh with HEX elements.

boundary-surfaces.png

This is the true geometry that is really associated with the solid body & HEX mesh in your model, as you see not any radial curves exist, you have two options:

  • Follow the recommendation of Ryan splitting the 3-D mesh using command MESH > EDITING > EDGE SPLIT, a great & magic command!!.
  • Or delete the two "isolated" boundary surfaces, delete ALL curves (only the disconnected curves will be deleted), delete ALL points (only free points will be deleted), delete the HEX mesh, and now play with the geometry of the solid: you can use command "Split point-to-Point" to split radially the tube and make sure to have a radial curve, and mesh the two base surfaces.

boundary-surfaces-solids.png

Simply using the MESHING TOOLBOX you can mesh the base surfaces with 2-D PLOT-ONLY elements, making sure the mesh quality is correct: use an element size of minimum 4/2=2.0, being 4 the wall thickness. Next extrude the 2-D mesh to create 3-D solid HEX8 elements using command MESH > SWEEP >CURVE and you are done!!

boundary-surfaces-mesh.png

Well, previously prescribe the mesh size in the curve used to perform the mesh extrusion using an element size = 2.0.

The final step will be to associate the generated 3-D HEX mesh with the 3-D solid body, use command MODIFY > ASSOCIATIVITY > AUTOMATIC, the final result will be the same as using the general procedure of meshing a solid with HEX elements, but following the above method you have control of all steps, OK?

Best regards and good luck!,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Problem with mesh control and editing

Creator
Creator
To T_Giampietro, Blas_Molero
Thank you so much.
Special thanks to Blas_Molero, your answers are always better than any guide

Re: Problem with mesh control and editing

Creator
Creator

Blas_Molero Thanks for the detailed answer.
But there is a small problem.
My body is a curve circular tube, so the GEOMETRY> SOLID> EXTRUDE command is not suitable. or I'm wrong?
so I do so:

1. create bondary surface and convert

2. Geometry-solid-sweep

In this case, I have coinciding curves. I can not delete them.
For comparison, the solid that was obtained with the help of commands GEOMETRY > SOLID > EXTRUDE - no problems

Then I use the command  "Split point-to-Point" to split radially the tube. As seen below, these solids are different

3.JPG

Then I define the sizes of a grid Mesh-mesh control-size along curve

and I have problems with generation of a grid for sweeped solid 

 

and one more question . Is everything right here?

1.JPG
if I use MESH > SWEEP >CURVE, I can get only plate elements.
probably correctly used MESH > SWEEP >ELEMENT?

 

 

 

Re: Problem with mesh control and editing

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Sorry, use MESH > SWEEP > ELEMENT, of course!.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: Problem with mesh control and editing

Creator
Creator

Thank you. but what can you say about this issue

1.JPG

If you need a file, it is attached in the post above

Re: Problem with mesh control and editing

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

Here the option of extrusion of a 2-D mesh is not possible, but please note you can use the general method of 3-D HEX meshing, not need to complicate things, this is a simply problem:

  1. First hide the two Boundary surfaces items in the GEOMETRY tree, do not mix boundary surfaces with surfaces of 3-D solids.
  2. Use MESH > MESH CONTROL > ATTRIBUTES ON SOLIDS and assign solid element type & material to the solid geometry.
  3. Next apply an element size to solid using MESH > MESH CONTROL > SIZE ON SOLID command, choose HEX MESHING option, use an element size = 2.0, and deactivate the option to adjust colors.

3d-solid-mesh-options.png

The result will be the following: please note the different number of divisions in the inner & outer circles, 41 & 47. To have a quality mesh simple change the number of elements in the circle edges to be the same, for instance 48 divisions.

3d-solid-mesh-size.png

Next use command MESH > GEOMETRY > HEX MESH SOLIDS and you are done, the mesh quality is perfect, all elements are HEX8:

3d-solid-mesh-final.png

Best regards,
Blas.

PD
I see you have defined a property named PLOT PLANAR PROPERTY, wrong!, this type of property is not necessary to define.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/