Showing results for 
Search instead for 
Do you mean 
Reply

Surface mesh issue

[ Edited ]

Morning all, first time poster here so be kind!

 

I'm having some trouble meshing an acute corner of an imported IGES surface. Some photos are attached.

 

I've cleaned up the surface after mesh prep and FEMAP has removed a section - is it possible to add an element to fill this void?

 

Any hints or tips welcome!

 

Cheers,

 

Alex

2 REPLIES

Re: Surface mesh issue

Good morning Alex,

 

What is the size of the gap in your IGES surface model?

Make sure your (local) mesh size is smaller than this gap size, else the mesh will just jump over the gap.

 

I've stopped using the Preparation function a long time ago.

I always use the 'Nonmanifold add' function (Geometry/Surface/Non-manifold add). This results in better intersections and merges all the surfaces together to one single geometry.

After this step I manually add the mesh size to the entire model: Mesh/Mesh Control/Size on surface and set the property Mesh/Mesh Control/Attributes on surface.

Now you can manually change the mesh size on specific curves for better detail or to properly mesh small details. This is done using the "size along curve" function. (Mesh/Mesh Control).

Pick your curve element size either as small as (or smaller then) your gap size.

 

The final step is to actual mesh your geometry, go to: Mesh/Geometry/Surface and select the surfaces you want to mesh.

Maarten Elings | Mechanical Engineer

Re: Surface mesh issue

When one sets the mesh size on a surface, there's a "Supress Short Edges" option set at 1% of the input Mesh Size.  FEMAP put a single node at the centroid of all connected suppressed edges, that's what is happening here.  One can turn off this option when mesh sizing.  After the fact, you can go to the Meshing Toolbox, and under Feature Suppression, use the "Curves" option, set the action to "Restore", and pick the curve and then both ends will get nodes and the edge will get an element edge.

 

Mark.