cancel
Showing results for 
Search instead for 
Did you mean: 

Surface xxxx has no facets

Genius
Genius

Hello,

 

I work with a model more weeks ohne problem, and unexpectedly by opening this model, Femap write error message "Surface xxxx has no facets", and in this model two solid's surfaces lost.

This error occurs long time ago in Femap, now in v11.2.2 too. Almost always will wrong that solid, which has been unchanged for days.

I read here in forum post about this error since 2008, but until today not fixed. In my case error occurs not due to sliver surface, and this solid came not from CAD geometry.

 

I attached the model with this solid.

23 REPLIES

Re: Surface xxxx has no facets

Experimenter
Experimenter

Hi,

 

It seems the reason your surfaces are giving errors is because they both contain a faulty curve:

Curve 9630 has a length of 1e-15 (practically 0).

Re: Surface xxxx has no facets

Genius
Genius

Hi bn255,

 

I found an older version of my model (see attached model), and lenght of Curve 9630 was 7,1034 earlier.

 

Best regard

 

Peter Kaderasz

Re: Surface xxxx has no facets

Experimenter
Experimenter

Hi Peter,

 

I no longer see any facet errors.

I can mesh the model fine (tet and plot only, but I did remove the surface approaches).

Re: Surface xxxx has no facets

Genius
Genius

Hi bn255,

 

that I wrote, with this geometry everything was OK, but meantime I worked with other part of model, this geometry was corrupted, and after next opening appeared the "Surface xxxx has no facets" message.

 

Best regards,

 

Peter Kaderasz

Re: Surface xxxx has no facets

Experimenter
Experimenter

Are you able to reproduce the problem?

Re: Surface xxxx has no facets

Genius
Genius

No, I can't reproduce, this problem occurs randomly in completely different models many years ago in all versions of Femap. I save my model after working day without error, and randomly next day I open it with error. I can repair solids, but annoying.

 

Peter

Re: Surface xxxx has no facets

Legend
Legend

Hi Kadpeter,

 

Simply delete those corrupted surfaces and do a rebuild to see if the "no facets" message appears again...

 

Regards,

 

Seif Eddine Naffoussi, Stress Engineer

Re: Surface xxxx has no facets

Genius
Genius

Hello SN,

 

I know, but then in my solid will be a hole, and I must repair the solid too (and the mesh size, mesh approch link to surface, etc.), when I want to mesh.

 

Best regard,

 

Peter Kaderasz

Re: Surface xxxx has no facets

Legend
Legend

Have you tried a Geometry / Solid / Cleanup ?

 

Seif Eddine Naffoussi, Stress Engineer