Cancel
Showing results for 
Search instead for 
Did you mean: 

bug with corner output on plates

Phenom
Phenom

Hello,

 

I've come across something which looks like a bug, or at least a situation for which I can't find a direct solution: I have a macro which computes output at corners for 2D & 3D elements, using the initElemWithCorner and putElemWithCorner methods. When a FEM contains both quads and trias, the output is properly created but is not shown on screen for trias. The fact that (linear) trias usually have no corner output might be what's bothering FEMAP. If I delete all corner output entries on trias (which are zero), my output appears properly on screen.

 

Am I missing something or is this a problem with the putElemWithCorner method / displaying output on trias?

 

Thanks for your help

5 REPLIES

Re: bug with corner output on plates

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

For CQUAD4, CTRIAR, and CQUADR plate elements, element forces, stresses, and strains are only calculated by NX NASTRAN at the centroid. You have the option to compute and output these quantities at the corner grid points setting the "Element Corner Results" customization at the NASTRAN Output Request in FEMAP. Then, to obtain the corner stresses in addition to the centroidal stress, you should request:

 

stress_corner.png

 

But for the CTRIA3 element the corner option is ignored for this element, this explains the problem.

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: bug with corner output on plates

Phenom
Phenom

Hello,

 

Thank you, yes indeed I suppose this is what bothers FEMAP.

But this is therefore a problem if you want to create custom output at corners in 2D elements via macro: FEMAP won't display the output on TRIAs if your selection contains both quads & trias.

 

The problem can be replicated on a simple model (cf below).

When I swtich to contour plot, elements 5,6,8, and 9 are colored with a single color corresponding to zero (real value should be 5,6,8,9 respectively). List>Output>Query works fine, and if I use Delete>Output> Entry and delete all corner output at TRIAs the contour plot changes and is better (though not perfect, something trickier happens on certtain trias but that's ok).

 

 

 

PSHELL         1       1      0.       1               1              0.
MAT1           1                              0.      0.      0.       
GRID           1       0      0.      0.      0.       0
GRID           2       0      1.      0.      0.       0
GRID           3       0      1.      1.      0.       0
GRID           4       0      0.      1.      0.       0
GRID           5       0      2.      0.      0.       0
GRID           6       0      2.      1.      0.       0
GRID           7       0      1.      2.      0.       0
GRID           8       0      2.      2.      0.       0
GRID           9       0      3.      0.      0.       0
GRID          10       0      3.      1.      0.       0
GRID          11       0      3.      2.      0.       0
CQUAD4         1       1       1       2       3       4               
CTRIA3         2       1       2       5       3                       
CTRIA3         3       1       3       6       5                       
CTRIA3         4       1       7       3       6                       
CTRIA3         5       1       6       8       7                       
CTRIA3         6       1       8       6      10                       
CTRIA3         7       1      10       8      11                       
CTRIA3         8       1      10       6       9                       
CTRIA3         9       1       9       6       5  

 

Then use the dummy macro:

 

Sub Main

    Dim App As femap.model

    Set App = feFemap()

 

    Dim os As femap.OutputSet, ov As femap.Output

                        Dim id(8) As Long, cen(8) As Double

                        Dim c1(8) As Double, c2(8) As Double, c3(8) As Double, c4(8) As Double

                        Dim c5(8) As Double, c6(8) As Double, c7(8) As Double, c8(8) As Double

 

    Set os = App.feOutputSet

                        Set ov = App.feOutput

 

                        os.Put(1)

                        ov.InitElemWithCorner(os.ID,9000000,9000001,9000002,9000003,9000004, _

                                               9000005,9000006,9000007,9000008,"test",FOT_ANY,False)

 

                        For i = 0 To UBound(id)

                                               id(i) = i+1 : cen(i) = i+1

                        Next i

                        c1(0) = 1.1 : c2(0) = .9 : c3(0) = .9 : c4(0) = .9

 

                        ov.PutElemWithCorner(UBound(id)+1,4,id,cen,c1,c2,c3,c4,c5,c6,c7,c8)

                        ov.Put(ov.ID)

End Sub

Re: bug with corner output on plates

Phenom
Phenom

ps: I'm on FEMAP v11.0.1, and "Use Corner data" is switched on. Swithcing it off changes the contour plot to something slightly better, but I don't want to lose the corner info

Re: bug with corner output on plates

Siemens Phenom Siemens Phenom
Siemens Phenom

Since triangles are linear all the way across, just add corner data for each triangle that is the same as its centroid, everything should work fine then.

 

Mark.

Re: bug with corner output on plates

Phenom
Phenom

Thanks Mark, that works indeed!

 

Whats confusing is that if you ask a tria3 for standard corner output, let's say stress, FEMAP returns nothing. So standard output can do without corner values, but macro output can't...? (I'm only talking about tria3s)