Cancel
Showing results for 
Search instead for 
Did you mean: 

DAT File mismatch by unforced using of "Comma" instead of "Decimal point"

Legend
Legend

Hello experts,

 

I'm using SimCenter 10 (10.0.3.5).

Every now and then I can't create a propper DAT file because NX uses the "Comma" character instead of the "Decimal point" character during creating the DAT file.

 

2017-11-07_165115.png

 

Is this a bug or a feature? - Mostly restarting NX did help but this time it didn't. Also restarting the computer didn't work. - What is wrong, what can I do? Replacing manually does not work because the file is really big and there are places where comma is correct.

 

The DAT file is for SOL601 but I don't think that's the point. I did solve a lot of SOL601 problems with that computer and I can't see any changes in hardware or software (except security updates of microsoft windows7-64bit).

 

Who can help?

Michael

 

PS: May be its not the right forum but I'd put it here and can't change it, sorry.

 

 

 

 

 

 

 

2 REPLIES

Re: DAT File mismatch by unforced using of "Comma" instead of "Decimal point"

Siemens Phenom Siemens Phenom
Siemens Phenom

Nastran does not consider the locale and always expects the decimal delimeter to be a decimal point (never a comma as that would affect parsing of free format (comma separated) card entries).

 

Due to this, the Nastran exporter from Simcenter also should ignore the locale settings for the current user account and always write decimal points.

 

If you are encountering a problem with this, please log a case with GTAC so they can work through the issue and debug it.

 

 

Re: DAT File mismatch by unforced using of "Comma" instead of "Decimal point"

Legend
Legend

JimB,

 

thank you for answering.

I think it doesn't belong to local settings here in Germany, where the comma is the separator for decimal digits less than zero as you described correctly. I did change it already in former times from "Comma" character to "Point" character to get rid of discrepancies in Excel.

 

The point is that 99 % of my exported  DAT files are correct with point character as decimal delimiter.

So I'm really confused.

 

Michael