cancel
Showing results for 
Search instead for 
Did you mean: 

NX NASTRAN - glued contact problem - shared node on master and slave

Creator
Creator

New question - I am trying to set up a contact pair in NX NASTRAN - SOL601,129 and in the .f06 file, it says that there are nodes that are shared between the master and the slave in GLUEMESH or BGSET.

 

Broadly, these are the steps that I am taking to set up the contact

 

1) I create a co-incident MMC between the three part bodies with a search tolerance of 0.025 mm and it goes and finds it, and then I click on "update" in meshing if/when it shows up.

 

2) Then I activate simulation and create a surface-to-surface gluing and because the geometry is complicated, I try and let it automatically find the contact surface pairs with the same search tolerance.

 

That seems to work ok.

 

I then set up my SPC constraint, and to make it simple, I just give it a 1 N load in the positive Z direction just to get the run going/see if there are issues with the contacts.

 

And sure enough, it results in a SOL601 fatal.

 

So, I am not sure what I should be doing differently to not have/let this happen, even though it's all created by the software.

 

(P.S. The contact pair face selections are on the polygon faces rather than the TETRA4 element faces.)

 

Hopefully, I have provided sufficient information about my analysis for people to be able to help me with it, but if you need to know more, please let me know.

 

Thank you in advance.

2 REPLIES

Re: NX NASTRAN - glued contact problem - shared node on master and slave

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

Check if the source of the problem is the "mesh co-incident MMC" feature, really when using GLUE contact the mesh not need to be coincident, Glue is a simple and effective method to join meshes which are dissimilar, the grid points on glued edges and surfaces do not need to be coinciden.

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: NX NASTRAN - glued contact problem - shared node on master and slave

Creator
Creator

Blas:

 

Yeah, I actually tried that after, and that seemed to work.

 

Interesting/funny how using the mesh matching connection appears to be the cause of this problem.

 

Thanks.