Cancel
Showing results for 
Search instead for 
Did you mean: 

Problem With analysis.exe

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

NX10 on my computer used to work normally but somehow when I start an analysis now, a window appears – “analysis.exe has stopped working” and the solution is killed in the very first seconds.

 

I’ve searched GTAC Solution Center but couldn’t find an appropriate solution. GTAC recommends to upgrade NX Nastran version which I do that. I’ve re-installed NX & NX Nastran, tried to increase memory, etc. but nothing happened. Still the analysis.exe crushes.

 

Interesting thing is – when I solve the .dat file from nastran64w.exe, it completes the solution as usual. But I can not solve it over NX window.

 

I’ll appreciate if you can help me on this. 

 

By the way, NX 9 & NX 10 are installed on my computer, NX 9 works fine.

8 REPLIES

Re: Problem With analysis.exe

Siemens Genius Siemens Genius
Siemens Genius

1. When you run the job from NX, do you get a log file/f06 file/f04 file? If so, attach the file so that we can see what is happening

2. Try to invoke "nastran64.exe" instead of "nastran64w.exe" from NX

 

Thanks

Easwaran

 

Re: Problem With analysis.exe

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Hello Easwaran,

 

1. The f06 & f04 file is empty. I've attached the log file.  

2. Maybe I couldn't able to explain it clearly. I'm using nastran64.exe indeed, while using NX interface. For this case, "analysis.exe" somehow stops working. When I use nastran64w.exe standalone (i.e. not from NX interface) and input .dat file, all the solution files including .op2 file are generated with no problem.

 

Therefore I assume that there's nothing wrong with NXN, but for some reason, something restrains "analysis.exe" to work when I solve model over NX.

 

Thank you for your help.

Ardic 

Re: Problem With analysis.exe

Siemens Genius Siemens Genius
Siemens Genius

From the log file, it seems no memory was specified. I'd recommend specifying 4gb memory in the NX solve form. I'd also suggest that you set the temporary file location in the nastran rcf file (see in the conf folder) to something other than %TEMP% which is the default on windows. That is, you'll need to set the scratch directory to a disk drive that has good performance.

 

You can also choose the executable to be "nastran64.exe" on the solve form in NX. This should also help you. Right now, this defaults to nastran64L.exe.

 

 

Re: Problem With analysis.exe

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Hello again,

 

I've set the memory to 4gb, set the scratch directory, changed and tried nastran executables such as "nastran64.exe" & "nastran64L.exe" but nothing changed. Solution still stopped in the very begining (with a windows error of "analysis.exe has stopped working"). 

Interesting thing happens when I set the solver version as 9 (since NXN9 is also installed on my computer) from "Solver Parameters" (1.png). Now there're no problems and the run completed normally. I've also attached log file, .f04 & .f06 files for debugging. 

Another interesting thing - Even if I've set solver version as 9, we can see that NXN10.1 is used during solution from .f06 file. 

Why is it so and what does it mean? I couldn't able to interpret on that. 

Thanks

Ardic

Re: Problem With analysis.exe

Siemens Phenom Siemens Phenom
Siemens Phenom

This looks like a problem with the new solution monitor in NX 10. When solver version is set to 10, NX will use the new monitor. To enable this from the Nastran side, NX adds "SYS(442)=2" to the solver command line. In this case, the last thing the .log file shows is:

 

Starting viewer with UGII_TMG_DIR set to 'C:\Program Files\Siemens\NX 9.0\nxcae_extras\tmg/exe'
Starting monitor viewer at C:\Program Files\Siemens\NX 9.0\nxcae_extras\tmg/exe/xcsmon_viewer.exe

 

When the solver version is set to 9, NX will use the old monitor. It adds "SYS(442)=1" to the command line.

 

To verify that this is the issue, set the solver version to 10 and toggle off the Solution Monitor on the Solver Parameters dialog.

 

The NX syslog may contain more information about why the monitor is failing.

Re: Problem With analysis.exe

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Hello Jim,

 

You're right. I've tried to turn off Solution Monitor and everything is OK. I've attached the syslog file. As you pointed out - SYS(442)=2 is written in the syslog file. 

 

But I couldn't debug more from syslog file. Can you help me on that? What to do right now, for the Solution Monitor not to fail?

 

Thanks.

Ardic

Re: Problem With analysis.exe

Siemens Phenom Siemens Phenom
Siemens Phenom

This is the appropriate time to get GTAC involved. Please open an IR so that they can formally investigate the issue.

 

http://www.plm.automation.siemens.com/en_us/support/gtac/index.shtml

Re: Problem With analysis.exe

Solution Partner Creator Solution Partner Creator
Solution Partner Creator

Thanks.  I'll do that and share their opinions.