cancel
Showing results for 
Search instead for 
Did you mean: 

new sim won't run

Phenom
Phenom

I'm trying to run a linear statics problem (sol 101) and the solver just refuses to run. For troubleshooting purposes, I've created a simple beam type problem (cantilever beam, one end fixed, other end loaded). I get "0 errors, 0 warnings" but the solver immediately exits. Only the .dat and .diag files are written, neither of which seem to indicate errors.

 

If I open an existing .sim file (one that was initially set up and run about a month ago), the solver will run normally. I can't seem to find any differences in the solver setup options.

 

Suggestions?

7 REPLIES

Re: new sim won't run

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

It could be many reasons:

• Make sure you are working in a sort PATH like C:\MODELS and all your model files there (*.prt files, *.fem, *.sim, etc..).

• Also check the nastran resources file (is an ASCII file to open with NOTEPAD.EXE) is located under <your_nx_dirextory>nxnastran\conf\nast9.rcf and make sure the nastran SCRATCH directory exist and you have rights to write on it. My suggestion is to use something like:

SDIR=C:\SCRATCH

• Any license error you have is wrtitten in both the LOG or F06 files, take a look to them.

Good luck!.

Best regards,

Blas.

 

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: new sim won't run

Phenom
Phenom

The .prt, .fem, and .sim files are all saved in the same folder on my C drive. The scratch location is set to my temp folder (also on my C drive). There are no .log or .f06 files created, only .dat and .diag; neither of which seem to indicate that any error has occurred.

Re: new sim won't run

Phenom
Phenom

Update:

Creating the same test model in NX 8.5.3.3 works; also works in NX 10.0.0.24.

Just won't work in NX 9.0.3.4.

Re: new sim won't run

Siemens Phenom Siemens Phenom
Siemens Phenom

Having absolutely no files created is a symptom of SDIR pointing to a non-accessible location.

 

To manually test, do the following:

 

  1. RMB on the solution and pick "Browse". This will open an explorer window in the solution folder.
  2. In this Windows Explorer window, hold down <Shift> and RMB on this solution folder. Pick "Open Command Window Here". This will open a command window in the folder containing the input deck, with all of the environment variables feom the NX session defined
  3. Open the NX syslog (File tab, Help, Log File). Scroll to the bottom and find the solver command issued by NX. Copy that entire command line and paste it into the cmd window created in step 2.

 

Any execution errors not recorded in the .log/.f06 should show up in this command window.

Re: new sim won't run

Phenom
Phenom

Here is the line from the syslog:

 

C:\Program Files\Siemens\NX 9.0\nxnastran\bin\nastran.exe -sld.2_sim1-solution_1.dat prog=bundle old=no scratch=yes sys442=1 | mode background

 

It choked on the spaces in the path, so I changed the command to:

 

"C:\Program Files\Siemens\NX 9.0\nxnastran\bin\nastran.exe" -sld.2_sim1-solution_1.dat prog=bundle old=no scratch=yes sys442=1 | mode background

 

This gives 2 errors:

  • invalid parameter - background
  • input data file must be specified on the command line

 

I changed it to remove the "background" command:

"C:\Program Files\Siemens\NX 9.0\nxnastran\bin\nastran.exe" -sld.2_sim1-solution_1.dat prog=bundle old=no scratch=yes sys442=1

 

It still gives the "input data file must be specified on the command line" error. I added the full path to the "-sld.2_sim1-solution_1.dat" file and it ran to completion.

 

 

So, how do I get NX to pass the correct parameters to the solver?

 

Re: new sim won't run

Siemens Phenom Siemens Phenom
Siemens Phenom

Does your .sim file name start with '-', i.e. -sld.2_sim1.sim?

 

The leading '-' might be throwing off the command line parser.

 

Your last iteration (without the " | mode background") is the correct command line for Nastran.

 

The fact that it ran with the full path indicates that Nastran or the file system is having a hard time dealing with the leading - in the filename. My guess is that if you rename the .sim and remove the leading '-', everything will start working.

 

Do the NX 8.5 and NX 10 version .sim files that worked also include the leading '-'?

Re: new sim won't run

Phenom
Phenom

DOH

Sometimes it's the simple things that you overlook.

In NX 8.5 and 10, our customer default options give a temp name to a new file in the format: model-sld_n

 

Apparently we forgot to set the prefix "model" name in NX 9 and it creates a new file with just -sld_n

 

Thanks to your sharp eyes, the problem is now fixed.