Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

AutoMeshColor.vb not running correctly

Dear Jim,

I run the program AutoMeshColor.vb, an NX OPEN for CAE utility that changes colors for mesh automatically.

 

Description:
This program will modify the color of all meshes in the .fem based on a user specified criteria. When executed, the user will be presented with a form containing 4 options:
1) By Mesh - each mesh will have it's color modified
2) By Collector - All meshes in the same collector will be colored the same
3) By Physical - All meshes with the same physical property will be colored the same
4) By Material - All meshes with the same material property will be colored the same

 

But I note selecting by MESH COLLECTOR the result is not correct:

  • Under 2-D MESH you see I have two collectors: SOPORTES (in cyan color) and TRAVIESAS (in red color). The program runs correctly,
  • But under 1-D MESH you see that ALL colectors has the same color (green), not matter being collectors mesh for BEAM, RBE2 or RBE3. I sould like to have one coor for each 1-D collector, running the same way as the 2-D collectors mesh, thanks!.

 

 

Best regards,

Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/
2 REPLIES
Solution
Solution
Accepted by topic author Blas_Molero
‎08-26-2015 04:32 AM

Re: AutoMeshColor.vb not running correctly

Blas,

 

This is standard functionality since at least NX 9, so there's no need to use the NX Open program. Go to Model Display and select the Element tab. Then choose the color basis for the meshes - the same options that you have in the NX Open program are available in the Model Display options.

 

I can't comment on why the NX Open program isn't working - my programming skills aren't what you'd think they'd be...

 

Regards,

Mark

 

 

Mark Lamping

Simulation Product Management

Product Engineering Software

 

Siemens Industry Sector

Siemens Product Lifecycle Management Software Inc.

mark.lamping@siemens.com

Solution
Solution
Accepted by topic author Blas_Molero
‎08-26-2015 04:32 AM

Re: AutoMeshColor.vb not running correctly

Blas,

 

As Mark stated, the need for this program was eliminated by out of the box functionality several releases ago.

 

If you still would like to continue to use it, toggle on the "Write detailed summary to list window" option. The output there should tell you why the color of the 1D meshes was not changed.

 

Jim