cancel
Showing results for 
Search instead for 
Did you mean: 

Error when activating "Run Solution in Parallel"

Creator
Creator

Hello,

 

I'm new user of NX Simcenter Thermal/Flow. To accelerate the simulation/calculation time of a coupled thermal-Flow 3D model by using Advanced Thermal-Flow, i want to activate the "Run solution in Parallel". However, there is an error as below:

 

Available nx Thermal/Flow parallel processing capabilities:

 

- Thermal Solver Parallel = Yes

- Flow Solver Parallel = Yes

 

Using MPI installation from

"C:\Program Files\Siemens\Simcenter 11.0\nxcae_extras\tmg/mpich2"

(default)

 

Traceback (most recent call last):

File "MPIvalidate.py", line 1451, in <module>

File "MPIvalidate.py", line 762, in TestMpirunIOPermissionsWindows

File "MPIvalidate.py", line 370, in CommandsGetOutputErr

UnicodeDecodeError: 'utf-8' codec can't decode byte 0xe8 in position 98: invalid continuation byte

Failed to execute script MPIvalidate

Message d'erreur_Solver parallel.PNG

I tried to follow the instruction by installing the mpich2 as described without success.

 

Does anyone have the solution ? It would be very hepful for me.

 

Thanks,

 

Ngda

 

8 REPLIES

Re: Error when activating "Run Solution in Parallel"

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Is the smpd service running in the task manager?

Re: Error when activating "Run Solution in Parallel"

Creator
Creator

It is not possible to have the smpd running in task manager. Do you know how to do it

What i tried:

  * smpd -stop

  * smpd -start

  * smpd -install

But it doesn't work !

Re: Error when activating "Run Solution in Parallel"

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

There are two possibilites:

 

  • cmd.exe needs to be in admin mode. Right click on the shortcut and select "Run As Administrator..."
  • mpich2 has not been correctly installed on the computer. I would suggest performing a clean install.

Re: Error when activating "Run Solution in Parallel"

Creator
Creator
Hi Zouya_Z,

Both suggestions do not work in my case. I tried another way without success:
* Run with admin rights: tmgnx.cmd from C:\Program Files\Siemens\NX 11.0\NXCAE_EXTRAS\tmg\com
* Type: PT to run the parallel tool, i got the same windows above without error
* After saving the xml file, i run the simulation with this xml, there is a new error:

QProcess Error: module terminated
+--------------------------------------------------------------------+
| |
| Distributed Parallel Execution: DOMDEC - Domain decomposition setup:
| encountered a problem and terminated abnormally.
| |
+--------------------------------------------------------------------+




+--------------------------------------------------------------------+
| END |
+--------------------------------------------------------------------+

Solution elapsed time: 04 min 38 sec

Have you any idea about it ?

Thanks

ngda

Re: Error when activating "Run Solution in Parallel"

Solution Partner Valued Contributor Solution Partner Valued Contributor
Solution Partner Valued Contributor

Does this happen on all models or just this one?

 

I would also suggest using the latest solver patch, if you haven't already installed it. You can get the latest patch from the GTACwebsite.

Re: Error when activating "Run Solution in Parallel"

Creator
Creator
Zouya_Z,

Thank you for the proposed solution. I'll keep you informed if it works or not.

BR,

Ngda

Re: Error when activating "Run Solution in Parallel"

Siemens Phenom Siemens Phenom
Siemens Phenom

If not solved yet, or maybe for others, have also a look at the following FAQ, it has some options you can check.

 

http://solutions.industrysoftware.automation.siemens.com/view.php?si=001-7911153

 

Kind regards,

Dennis de Brouwer
Application Support Engineer
GTAC EMEA - Siemens Industry Software

Re: Error when activating "Run Solution in Parallel"

Creator
Creator

Thanks Dennis for your clear solution.

 

Finally, i have managed to activate this kind of parallel calculation. As said Zouya_Z, i tried to update the Thermal/Flow solver by getting the latest version (11.0.8 of march 7th). It works very well.

 

Many thanks for your exchange

 

BR,