Showing results for 
Search instead for 
Do you mean 
Reply

Lost of thickness information after importing .dat file

Hello everyone!

 

I have a shell model with all element thicknesses fully defined in a FEM file. I have had to export the simulation in the .dat format so that I can modify several lines with some code of mine. An excerpt of the .dat file looks like this:

Untitled.pngBy looking at the second line of every CQUAD4 section, it is clear that the thickness information has been included in the exported .dat file. However, when I import this same .dat file into NX again as is, without changing anything, the thickness information could not be read and my FE model has zero thickness throughout. 

 

Looking at the import information window, the following errors appear:

Untitled1.png

 

What's bugging me is that the thickness information is in the exact format that has been exported from NX and yet NX can not read it back in and recreate the FE model with the same thickness. Has anyone come across this issue before? Any help will be appreciated!

 

 

 

 

 

 

 

 

 

1 REPLY

Re: Lost of thickness information after importing .dat file

[ Edited ]

Have you edited the deck between the time it was exported and when it was imported? The error shown indicates that there is no PSHELL with PID=1 in the deck. Assuming it was exported correctly, did you remove or comment out the PSHELL card from the deck?

 

Corner thicknesses from C* continuation lines are stored as element associated data in NX. You can examine element associated data to verify this.

 

A more fundamental question would be why you are exporting a deck from NX, then re-importing it. Any edits you need to make to the deck should be able to be accomplished in NX.