Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Path length

Hello guys,

 

I have one short question.

 

I want to import some universal files produced by NX in previous steps. By trying to import the results I always get an error message, that no results are found. I guess the problem is a to long path name.

 

Does anybody know, is it possible in NX to allow somewhere to work with longer path names.

I don´t want to copy these folders somewhere, because the files are huge and additonally there are a lot of path dependent macros implemented.

 

Regards,

 

Georg

5 REPLIES

Re: Path length

Georg,

 

Did you verify that if you move the UNV to say the root directory, that NX works as expected? If that fails, then I would check the UNV to see if it contains node and element data in addition to the results.

 

Are you attaching the results to an existing solution that has results or importing the results? Import requires that the nodes and elements exist in the UNV. Attaching the results to a solution leads to NX using the nodes and elements in the solution's results file for the post processing display of the UNV based results.

 

I don't know what to do if it is strictly a file path length issue, aside from shortening the path.

 

Regards,

Mark

 

Mark Lamping

Simulation Product Management

Product Engineering Software

 

Siemens Industry Sector

Siemens Product Lifecycle Management Software Inc.

Mark.Lamping@siemens.com

Solution
Solution
Accepted by topic author GStrickner
‎08-26-2015 04:32 AM

Re: Path length

Georg,

 

I would also suggest first verifying that the .unv file contains all necessary information by copying it to a short, valid path (no spaces or special characters either), i.e. C:\TEMP\test.unv

 

Assuming that the file is valid and works there, you have 2 options:

 

1) Move it to a path with a shorter total length

2) Share the folder containing the .unv file. You should then be able to access that folder with the UNC name.

 

For example, if the .unv file is in D:\this\is\a\long\path\to\results\analysis.unv

 

Share the results folder

 

If the workstation name is MyPC, you shuld be able to access the file using \\MyPC\results\analysis.unv

 

Regards,

Jim

 

Re: Path length

Hello guys,

thanks for your hints.
Yes, I checked the UNV files. I also tried to import one UNV file for a shorter directory. It was also working.

I guess the tip from Jim to share the folder is a good solution for such cases. I will try this in futrue.

For now I found out, that it is possible just to make a new empty solution. There you first have to click with the RM to Results and click on Specify.
Once set the first file again click with RM on Results and use Add companion results and include all UNV files you want.

Regards,

Georg

Re: Path length

Hello

you are welcome

Long path tool is the best solution for your problem. try it and solve your problem

 

__________________

Re: Path length

Hi there

 

windows path length is limited since MS invented the thing. There's a well known constant called MAX_PATH which makes peoples lifes worse than needed.

 

There's an alternative to sharing a directory however: subst

Check the manual here: subst