Showing results for 
Search instead for 
Did you mean: 

Access violation" (C0000005)



I'm currently working on a water tank cradle model. I have troubles finishing it. When i run the job NX Nastran crashes and the solver doesn't give me any error code. Actually sometimes the job finishes ok but most of the time it doesn't (90%). I need to do a few test runs before i can make final adjustments to the model but this error kinda makes it impossible.

Inside the f06 and log file there is this line:


MAIN: "Access violation" (C0000005) exception encountered.
MAIN: For reference, A(MAINAL) = 13FDD1090, A(/SYSTEM/) = 142B88720
MAIN: A(/OPENZZ/) = 180140040
MAIN: Exception occurred at address 0000000140DAB260.
MAIN: Program attempted to access data at location FFFFFFFFFFFFFFFF.
MAIN: Context Flags 0010005F


It looks like the solver crashed while attempting to access certain memory area.


I'm fairly sure that the issue is linear contact in my model. I used surface to surface linear contact to determine certain displacements. At first the solver was crashing. After i changed surface to surface contact to element to element the job finished ok. But then i needed to replace the contact with a dozen of GAP elements to run nonlinear analysis. Now the solver crashes constantly.


So the problem is - nx nastran sol 101 crashes while performing an analysis of a model with GAP elements used as linear contact (i have that option checked in analysis options).

Really need your help guys!


I use Femap 11.2.

I attached f06 and log files


Re: Access violation" (C0000005)


Hi Musicus,


I had this error earlier too:


 MAIN: "Access violation" (C0000005) exception encountered.

 MAIN: For reference, A(MAINAL)   =        13F301090, A(/SYSTEM/) =        141C83D60  

 MAIN:                A(/OPENZZ/) =          2910040                                  

 MAIN: Exception occurred at address 000007FEED92875C.

 MAIN: Program attempted to store data at location 0000000000000000.

 MAIN: Context Flags 0010005F


I can solve my problem with modifying NASTRAN SYSTEM(206) variable (it's default value is 4) in Nastran Executive and Solution Options, and the buffer size in the Nastran config file. I ran tests with a model (with lot of nodal Constraints), and became the following results:


NASTRAN SYSTEM(206)=9: Stopped with Access violation error, error code C0000005


NASTRAN SYSTEM(206)=1: without error, running time 00:59:52

NASTRAN SYSTEM(206)=2: without error, running time 01:42:18


When I became Access violation error (C0000005), I increase buffer size, and the running of the analysis finished without error.


Here is the description about SYSTEM(206) DCMPSEQ from Nastran Help:


Selects ordering method for sparse matrix decomposition.

0: EXTREME for 3D, Metis or MMD for 2D

1: MMD – definite matrices

2: MMD – indefinite matrices

3: No sequencing

4: EXTREME (Default)

8: Metis

9: Better of Metis and MMD

32: MLV

+ 64 (adding 64 to any of the above values): Turns

on Supernodal Compression Scheme. For example,

sys(206)=72 would indicate Metis (8) + Supernodal

Compression Scheme (64).


Best regard,


Peter Kaderasz

Re: Access violation" (C0000005)


Thank you for your reply, Peter!

I have a feeling that your suggestion is right on point. Today i tried doubling BUFFSIZE and after that the job finished without any error! I was using BUFFSIZE 65537 previously and i thought it's max allowed value. I didn't even have to try changing system(206) value.

Could someone please explain what BUFFSIZE actually is (preferably in simple terms)?

For now it looks like everything is ok but i still need a few days to test things out.

Re: Access violation" (C0000005)


Welp, i did a lot of testing today aaaaaaaaand the issue is still there. I keep getting this nasty error. I learned that BUFFSIZE 65537 actually IS max value so increasing it has no effect. I had no luck with changing system(206) value either.

Still need help guys!

Deadline is near. I'm in trouble! Cat Sad

Re: Access violation" (C0000005)

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Dear Musicus,

Post your model to take a look to it, we will see what happens really.

I see reading your LOG file the following:

Current Dir: E:\Work\27. Ëîæåìåíòû ïîä áàê îòõîäîâ

This is totally wrong, the path for the NX Nastran solver should be clean, not spaces, not any characters are valid, try to use simply names for FEMAP models without spaces.

Best regards,


Blas Molero Hidalgo, Ingeniero Industrial, Director
Blog Femap-NX Nastran:

Re: Access violation" (C0000005)


Hi Blas,


since many years I use SPACE characters in path and file names, and non-english characters too (for example "á"). It's work, the analyses finished without any errors. For example more then one years ago I ran an analysis:


Current Dir: D:\Data\Futómű\HLL_gömbgrafitos villa


Best regards,


Peter Kaderasz

Re: Access violation" (C0000005)


Hello everyone!

Time passed and i think i figured out what was the problem. As i said before i was pretty sure that the issue was caused by linear contact.

I wanted to make one of the contacting bodies rigid compared to the other one so i made a custom material for it with E=200 000. It was contacting the body with E=7000 material. So i think the huge difference in Young modulus caused this strange memory access error. I lowered the first value to 6000 and never got the error since then. I performed something like ~50 jobs.

Also i had weird singularity errors because of insane compression stiffness of GAP elements (something like 10^26).