Cancel
Showing results for 
Search instead for 
Did you mean: 

FEMAP - logfile

Experimenter
Experimenter

I am a starter of FEMAP. During "Analyze" after modelling and meshing, I got a message as "Unable to open C;\.\.\..........xyz.log logfile for reading. Please check file manually and confirm licensing.". Then I made a serach in my computer and can not find the xyz.log file. What should I do?

14 REPLIES

Re: FEMAP - logfile

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Dear TW,

From the distance (without having remote control of your local computer and see what really happens) for me the souce problem is located in the SDIR variable of NX NASTRAN: either do not exist, or if the PATH exist you do not have wrtitten permission to write the LOG file.

 

The SDIR Keyword is used to set the directory for temporary scratch files produced by NX Nastran. It is critical for the performance of NX Nastran that it points to a local scratch drive with plenty of disk space. For FEMAP & NX Nastran you can set the “sdir” keyword in the NX Nastran configuration file (nastran.rc on Linux, nastX.rcf on Windows, being X ythe version of nastran) located in the "<FEMAP-installation-directoy>\nastran\conf", edit the file with NOTEPAD.EXE and enter a valid PATH for the SDIR variable, the one I run is the following:

 

NX NASTRAN Configuration File

It is recommended that you disable virus checking for the scratch directory to improve the performance of the NX Nastran solution.

To learn more please visit my block in the following address:

http://iberisa.wordpress.com/2014/01/03/requisitos-hardware-de-nx-nastran/

 

Best regards,

Blas.

 

 

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: FEMAP - logfile

Pioneer
Pioneer
Hi Guys,

I'm getting the same error as TW above. My desktop can't find the log file (which is because it's not being output to the directory, or anywhere else). Running the same .modfem file on my laptop allows it to compute, so I'd guess its a settings or setup problem.

I've checked the . rcf file mentioned above and its pointing to a directory with read/write permission. I've also checked in settings and the analysis output which are all identical to that on my laptop. Further to this, I've tried to uninstall and reinstall to reinstate the default settings but still no success.

Has anyone any suggestions, please?

Thank you

Re: FEMAP - logfile

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

Delete (or move) all you nx nastran files in the SCRATCH directory (*.dat, *.f04, *.f06, *.op2) and also in your OUTPUT directory, take a look to my post in this thread:

https://community.plm.automation.siemens.com/t5/CAE-Simulation-Femap-Forum/Question-about-adding-Old...

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: FEMAP - logfile

Pioneer
Pioneer

Hi Blas

I've tried this and the suggestions in your other post without success. There is still no .log file being created in any directory on the PC. What is created is a series of .dat files with the names: base_name-001.dat. I have no f04, f06, op2 files whatsoever. The only FEMAP file is the .modfem file.

 

Any thoughts?

 

 

Re: FEMAP - logfile

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Post the exact error message, thanks!

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: FEMAP - logfile

Pioneer
Pioneer

 

Hi Blas, 

This is what is displayed in the error message: 

Opening File \Documents\Projects\Standard\standard-002.dat...
Writing Case Control...
65038 Element(s) Deleted. 0 NonDeletable Element(s) Skipped.
2 Coordinate System(s) Translated.
0 Constraint Equation(s) Translated.
0 Constraint Set(s) Translated.
8 Property(s) Translated.
8 Material(s) Translated.
0 Constraint Set(s) Translated.
2771393 Node(s) Translated.
1831438 Element(s) Translated.
WARNING: Writing Connector 23: First Contact Property 4 will be used as global BGPARM definition.
Solve Using Integrated Solver.
Unable to open C:\tempfea\standard-002.log logfile for reading. Please check file manually and confirm licensing.
Unable to open C:\tempfea\standard-002.log logfile for reading. Please check file manually and confirm licensing.
Unable to Load Results during another command.Finish or abort current command, then load results manually.

 

 

Re: FEMAP - logfile

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Hello!,

I suggest to make things easy:

  • Create a new directory, say C:\MODELS
  • Save the FEMAP database there, use a simply model name: MODEL1.modfem
  • GO to FILE > PREFERENCES > INTERFACES > NASTRAN OPTIONS and make sure that "DIRECT OUTPUT TO = 1..Model File Directory", this way FEMAP & NX Nastran output files will be together in C:\MODELS

... and tell me what happens.

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/

Re: FEMAP - logfile

Phenom
Phenom

And... are you the only person who uses this computer?  Have you run analysis on this computer successfully before? Can you save and edit files in the Nastran scratch directory?

 

If you have deleted earlier .dat files, are you 100% certain that you also deleted all the other associated nastran files (eg.Standard-002.f04, f06, .op2, mon1 .asm .log etc.).  If not , either delete them OR as a fast method to check, Save As some other model name and re-run the analysis.

 

Cheers,

Re: FEMAP - logfile

Pioneer
Pioneer

Hi Blas,

 

Thanks for your help - this has now computed successfully! Smiley Happy

 

Do I need to run all analysis in the same way or can I split the model file  and the other files again?