Showing results for 
Search instead for 
Did you mean: 

Larger scratch space required for V11.3?


We recently made the switch from FEMAP (NX NASTRAN) V11.2.2 to V11.3.2.  I have been working on a fairly large model lately (1.7 million degrees of freedom) - it was solving in 47 minutes, and required aproximately 100 GB free space for the scratch file.  Since updating, it has been failing due to lack of scratch file space, and taking longer to run.  My last run had 131GB free for the scratch file, and it ran for 1 hr 22 minutes before failing.


Most of the model is midsurfaced, but I have a number of components that will be cast in production - these I meshed as solids.  As an experiment I saved the model elsewhere, replaced the solid components with rigid elements, and solved the model in 30 seconds.  So it's definitely the solid mesh elements that are driving up the solve time.


My question is, did something change in the solver from 11.2 to 11.3 that increases the necessary scratch space, and is there any way to work around that?


Re: Larger scratch space required for V11.3?

Siemens Phenom Siemens Phenom
Siemens Phenom

Moving from 11.2.2 to 11.3.2 means you have updated the Nastran solver from NXN10.2 to 11.0.

The default settings for memory and scratch location are the same in both versions as delivered with the default install.

When scratch space requirements increase like that, usually the root cause is insufficient memory for the solver which results in using "spill" to disk space to perform the decomposition.

So, maybe you had some things set in Femap preferences for the old version that are affecting your resources. Here is a list of things to compare between the versions:

did you request ILP solver for either version? This changes memory allocation. (4byte/word vs 8byte/word)

did you set scratch directory for Femap? and also for Nastran?

are you using the default(blank) for the solver memory?( that is the best option since NXN 10.0)


If nothing is obvious when comparing, then if you post your f04 file from the run, we can understand what resource issues you are having and suggest a solution.




Re: Larger scratch space required for V11.3?


I hadn't requested the ILP-64 solver for V11.3.2 - doing so solved my issue.  Thanks for taking the time to help troubleshoot this.