Cancel
Showing results for 
Search instead for 
Did you mean: 

Matched surfaces tolerance

Creator
Creator

 

Good day to all

As shown in attached pictures I'm having problem with meshing matched surfaces. Using Mesh size on solid (as shown on Figure 2) I automatically get matched surfaces, but meshing solids I get some mismatched nodes. The reason for this can be seen on Figure 4 where I have same mismatching of edge curves (order of magnitude e-4).

I tried multiple approaches to fix this and I had success on similar problems in past but this time I just can’t find one that works.

I tried:

1. deleting matched surface on one solid, coping matched surface from other solid and stitching back first solid with copied surface

2. combining two solids to one and removing one of two to get adequate matched surface

3. cutting matched surface in multiple surfaces to localize problem 

4. combining two solids to one and using Solid Slice With Sheet Solid

Note that surfaces are generated using splines so they are very sensitive to any change.

Geometry>Solid>Cleanup is sadly out of question as Advanded Geomety Cleanup options changes geometry after which surfaces are not automatically matched.

My question:

Is there a tolerance value that controls nodes on matched surfaces that can be merged during tet meshing?

I ask this because I have similar mismatched curves on different solids and on them mesh is generated without this problem.

Additionaly I’m having great problems importing such geometry as 3D model is prepared in AutoCad...

Importing this model to Femap as .stp .step doesn't give solid bodies and I ended up using .sat format.

Any advice is greatly appreciated

Thanks

 

1.pngFigure 12.pngFigure 23.pngFigure 34.pngFigure 4

3 REPLIES 3

Re: Matched surfaces tolerance

Gears Phenom Gears Phenom
Gears Phenom

I do not know if this could help you.

 

But once I did this:

- take each solid. Explode . And then stitch each solid with tolerance 1e-4 or 1e-3

- then, mesh with adjacent surface matching

 

Hope helps

Re: Matched surfaces tolerance

Creator
Creator

Thank you Jon I tried your method but sadly without success.

For this problem I used a workaround.

 

Using Mesh Size On Solid, without Adjacent Surface Matching I defined element size, then generated plot planar elements on one solid and used Modify>Associativity to associate those plot planar elements to second solid. This way plot planar elements were used as seed for tet meshing second solid after witch I simply merged nodes between solids.

Re: Matched surfaces tolerance

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom

Dear Milan,

If possible post both your geometry source file & FEMAP model here to take a look to it, this way we can investigate the real problem and give you an exact solution. In general is a question of tolerances, that get worse when working in units meters. Make sure to work in milimeters setting the Solid Geometry Scale Factor = 2 under FILE > PREFERENCES > GEOMETRY/MODEL, this will cause to use a factor of 1000 when importing any STEP, SAT or Parasolid geometry file to get the length in milimeters.

femap_tips_tricks_preferencias_geometry.png

Best regards,
Blas.

Blas Molero Hidalgo, Ingeniero Industrial, Director
IBERISA • 48004 BILBAO (SPAIN)
WEB: http://www.iberisa.com
Blog Femap-NX Nastran: http://iberisa.wordpress.com/