Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Customer Defaults for Post Processing

Creator
Creator

Thanks MiDi1791,

 

I will try to do someting different to apply small amount of templates.

 

I will show you my results when it succeeds!

 

Greets,

Jeroen

Re: Customer Defaults for Post Processing

Creator
Creator

Mr MiDi1791,

 

We have 2 templates but it doesn't combine the result.

Only 1 tempate is shown in the post processing view.

How do i combine these two templates? see picture. 

 

Shown in the picture is no edge style but we see a deformation of 10% we want to see this 0% and no edge style.

 

Can you help me with this problem?

 

Greets,

Jeroen

 

 

Re: Customer Defaults for Post Processing

Creator
Creator

We have this code as tempate:

 

but this doesn't work this way...

 

i think we do someting wrong here. 

Re: Customer Defaults for Post Processing

Gears Phenom Gears Phenom
Gears Phenom

JBrouw96,

 

I believe you did not activate the templates.

You should right-click onto template "No Deformation" and apply it and afterward you must right-click onto template "Edge_Style" and apply it, too.

 

Michael

| Production: NX10; Development: VB, TCL/TK, FORTRAN; Testing: NX11 | engelke engineering art GmbH, Germany
| Kudos for good posts! And if my post answers your question, please mark it as an "Accepted Solution".

Re: Customer Defaults for Post Processing

Creator
Creator

Ok,

thank you for all your help so far.

 

We have activated the templates but that doesn't work, what should we do now?

 

Greets,

Jeroen

Re: Customer Defaults for Post Processing

Gears Phenom Gears Phenom
Gears Phenom

JBrouw96,

 

put each template into a separate file or

 

remove the inner lines

</PostView>

</NXPostprocessingTemplate>

<Postview>

 

and add

</PostView>

</NXPostprocessingTemplate>

 

at the end.

 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

 

<NXPostProcessingTemplate TemplateType="User" Version="NX8.5" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:noNamespaceSchemaLocation="PostTemplate.xsd">
	<PostView>
		<DeformationOptions>
			<ShowDeformation>0</ShowDeformation>
		</DeformationOptions>
		<EdgefaceDisplayOptions>
			<PrimaryOptions>
				<EdgeStyle>None</EdgeStyle>
			</PrimaryOptions>
		</EdgefaceDisplayOptions>
	</PostView>
</NXPostProcessingTemplate>

<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

 

Save it as "NXPostTemplate_USER_001.xml" in your template directory and reload your templates.
Then you should see it and it shall make what it has to do. In my environment it works.

 

=> No Edges => No Deformations

 

 Best wishes, Michael

| Production: NX10; Development: VB, TCL/TK, FORTRAN; Testing: NX11 | engelke engineering art GmbH, Germany
| Kudos for good posts! And if my post answers your question, please mark it as an "Accepted Solution".

Re: Customer Defaults for Post Processing

Creator
Creator

Thank you very much Michael we really appreciate your effort! 

Re: Customer Defaults for Post Processing

Creator
Creator

It works!! 

 

Thank you very much for your help.

 

Jeroen

Re: Customer Defaults for Post Processing

Gears Phenom Gears Phenom
Gears Phenom

Jeroen,

All right, feel free to arrange all you setting for post views now ;-)

I think the larger problem ist to find good names and keep control.  Sometimes templates also vanish! - Therefore make backups!

 

Best wishes, Michael

 

| Production: NX10; Development: VB, TCL/TK, FORTRAN; Testing: NX11 | engelke engineering art GmbH, Germany
| Kudos for good posts! And if my post answers your question, please mark it as an "Accepted Solution".

Re: Customer Defaults for Post Processing

Creator
Creator

Yeah true, that is a risk we have to take. 

 

Thanks again!

 

Jeroen