Highlighted

How do I reduce 'maximum node label used' in assembly FEM?

Creator
Creator

Hi Community Members,

 

I am working on model in which multiple .afm are assembled at diffrent diffrent level of model tree.

 

 

 

When I look at 'Finite Element Model Summery' at top level of .afm , my total number of nodes in the part : 1097874.

While maximum node label used : 2129107798. 

 

There is a huge gap in nodes number: 2129107798 -  1097874 = 2128009924

How do i overcome this gap so that maximum node label used will be close to actual nodes present?

 

MESH SUMMARY OF ENTIER MODEL

Total number of elements in the part : 872584
Total number of nodes in the part : 1097874
Number of Concentrated Mass elements : 44
Number of Rigid Link elements : 1521
Number of RBE3 elements : 1416
Number of Quad4 elements : 57325
Number of Tri3 elements : 8169
Number of Tetra4 elements : 221144
Number of Tetra10 elements : 582965
Minimum element label used : 1473123135
Maximum element label used : 1723513837
Minimum node label used : 1891126835
Maximum node label used : 2129107798

 

 

 

Below is the mesh summery of one of the .afm in which only one part is assembled. Even in this case nodel label is exceeding the present node number. 

Un-accounted node numbers in .afm with one part: 29034 - 25884 = 3150

 

MESH SUMMARY OF ONE OF THE INDIVIDUAL PART

Total number of elements in the part : 12940
Total number of nodes in the part : 25884
Number of Concentrated Mass elements : 1
Number of RBE3 elements : 1
Number of Tetra10 elements : 12938
Minimum element label used : 3075
Maximum element label used : 16014
Minimum node label used : 3151
Maximum node label used : 29034

 

 

I would like to reduce nodel label used in my model to an extent total number of nodes present in the model.

 

 

 

I have tried following things but didnt suceeded in lowring node number:

 

1. Renumbering node ID from 1 at each .afm lavel going from bottom to top  in assembly tree.

2. Assembly label manager tried to keep node offset 1, but it dosent accept it when I press automatically resolve. It autoamtically overrides 1 and put some number.

 

Can anyone suggest how do I approach this proablem?

 

Thanks 

Jay

 

4 REPLIES 4

Re: How do I reduce 'maximum node label used' in assembly FEM?

Phenom
Phenom
  1. re-number every .fem from 1 with no gaps in the numbering or gaps you are hapy with. For example I ususally "reserve" num ber 1-1000 for key stuff I want t output
  2. In the .afm offset numbering with min gap between parts

I usually have  a numbering system based on the part

fem1 1,000,001

fem2 2,000,001

fem3 3,000,001

etc

Production: NX.CAE 10.0.2.6
Development: VB.NET (amateur level !)

Re: How do I reduce 'maximum node label used' in assembly FEM?

Siemens Legend Siemens Legend
Siemens Legend

Capture.PNG

 

Hello

Could you tried this ?

 

Re: How do I reduce 'maximum node label used' in assembly FEM?

Creator
Creator
I did element -node ID reset from 1 for each fem and on top of it in .afm I reseted assembly label with power button.

I repeted this exercise at each leval going bottom up in the tree. It worked, at the end node number did reduced.

The entier process is very labourious, can any one suggest how can I automate certain repetative tasks like, resetting node ID in each .fem

Re: How do I reduce 'maximum node label used' in assembly FEM?

Phenom
Phenom

use the 'automatically resolve' option in the assy label manager

Production: NX.CAE 10.0.2.6
Development: VB.NET (amateur level !)