Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Java problems in response dynamics

Pioneer
Pioneer

Hi All,

 

I'm attempting the Simcenter 12 response dynamics tutorial and on trying to activate the "Function Tools for Reponse Dynamics", I get a Java error. 

 

The tutorial has recognised that Java problems occur at this point and attempts to guide the reader into fixing the issue (see attached picture that shows the command I'm attempting, the guidance presented to the reader and the errors that I see).

 

I've tried numerous attempts at various filepaths in the ugii_env.dat file and also tried to use the "Override Java Parameters" command, but I continue to see the errors.

 

I do have an up-to-date Java installed and I have tried various path descriptions. I've also restarted the machine after changes to the ugii_env.dat file.

 

Any help would be much appreciated.

 

Thanks in advance.

3 REPLIES

Re: Java problems in response dynamics

Siemens Phenom Siemens Phenom
Siemens Phenom

If you are running Simcenter 12.0.1, there is an issue due to afuapp.jar not being signed. See PR 9131111

 

The issue will be fixed in 12.0.2.

 

Contact GTAC to obtain an updated copy of a properly signed executable for 12.0.1.

 

 

Re: Java problems in response dynamics

Pioneer
Pioneer

Many thanks Jim,

 

I've requested my support company to get this from GTAC, as I don't have access.

Re: Java problems in response dynamics

Pioneer
Pioneer

Hi Jim,

 

I contacted my support people and they said that their system works OK with 12.0.1 and mp02 installed with the latest Java.  Hence I should update from 12.0.0.

 

I've now updated, but I have the same problems, speciifically I get the "no java author license is available to be able to run this java class file" error.

 

I am unable to make requests on GTAC, but I can download files.   Do you know if I can get the properly signed afuapp.jar executable directly.  My support company have gone home for the weekend!

 

Thanks.