Iterative solver not working but direct sparse is...


I have an issue where the direct sparse solver is working but not the iterative solver. When I use the iterative solver i get the following message:


"Iterative solver failed due to insufficient memory"


Model data:


Nodes: approx 800 000 (HEX8 and HEX20 and few TET10) Only solid elements.

Contacts: Yes. One contact definition.




Not sure what I am doing wrong? I tried to make the mesh coarser (got approx 170 000 nodes) and used the 64L.exe. I even tried to run sol103 to check if there were some areas that was not glued together.


I am runing the simulation now with direct sparse solver. 2 hours 30min now and still counting. I have noticed that the iterative solver is much faster than the direct sparse solver so if anyone has any ideas that would be great.




Re: Iterative solver not working but direct sparse is...

Solution Partner Phenom Solution Partner Phenom
Solution Partner Phenom


You need to allocate more RAM memory to the NX NASTRAN solver, try using 5GB.  If failed, use 6GB and so on, but not more than 7.9GB that is the limit for the regular NX NASTRAN LP-64 solver (4 bytes-per-word). Another option is to use the ILP-64 executable of NX Nastran.


To learn more about the NX NASTRAN executable please visit my blog in the following address:

Best regards,

Blas Molero Hidalgo, Ingeniero Industrial, Director
Blog Femap-NX Nastran:

Re: Iterative solver not working but direct sparse is...




Thanks for reply. I forgot to mention this in previous post. I used the other executable that allows for higher memory and I used 20GB for memory allocation (12GB free for I/O) and parallell=2 or 4 (cant remember what I put in). I can post the f06 file tomorrow.


I did try this with coarse mesh (apporx 170 000 nodes) with glued contacts (no sliding) and the direct sparse solver solved this in 12 minutes. I get a fatal error with iterative after 2-3 minutes, after the "large" gap warning. I checked the glued gaps and the search distance in all the simulation objects. There should not be any problems there which is also confirmed by the SOL103 simulation.


I did manage to get model to solve with the iterative solver earlier, but the problems started when I refined the mesh in some areas in the model.