Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Open Edge Device Kit (OEDK) Status Messages

Experimenter
Experimenter

Yes, I’m aware of these access issues. I solved it by changing the installation script. Instead of the ‘isbuser’ I used the ‘root’ as the default user. In the Docker container, all OEDK components are executed as root also.

 

Change default user to ‘root’:

defaultUser="root"

Do not add a new user by comment out this line:

#id -u $defaultUser &>/dev/null || useradd $defaultUser

I already have tried a lot of things, so I wanted to know if the JRE could have an impact.

 

As prerequisite for the OEDK is JRE 8 listed. Because of changing Terms of use by Oracle this version is not longer available in the repositories of Linux distributions. So, I used the Oracle JRE 11 (LTS).

 

Because the Docker version works, I checked which JRE is used. I found an OpenJDK version:

openjdk version "1.8.0_131"
OpenJDK Runtime Environment (IcedTea 3.4.0) (Alpine 8.131.11-r2)
OpenJDK 64-Bit Server VM (build 25.131-b11, mixed mode)

Next I have installed the current version of openjdk-8 (1.8.0_212). With this JRE something has changed: A token file will be generated now, and the connection status goes to online. However, I received other error messages:

[ER] DeviceHealthUploadStage_36 | c.s.m.a.d.e.j | Reporting device health failed Operation failed. Response: <{"errors":[{"message":"Request body is not valid","code":"mdsp.core.devicestatus.invalidRequest","logref":"5d15e948731615ed65cbf115136dd37a"}]}>.)
[ER] DeviceHealthReaderStage_34 | c.s.m.a.d.e.i | Reporting device health failed java.lang.InterruptedException

The healthy status of data points does not work.

 

I suspected I was on the right track, now I wanted to install Oracles JRE8. I found an archive (update 211) for a manual installation:

jre-8u211-linux-x64.tar.gz

 

One possibility to install it manually:

 

  1. Unzip and extract the archive
  2. Create as root a folder '/opt/Oracle_Java'
  3. Copy the content of extracted archive to the new folder
  4. Setup an alternative installation
    sudo update-alternatives --install "/usr/bin/java" "java" "/opt/Oracle_Java/bin/java" 1
    sudo update-alternatives --install "/usr/bin/java" "javaws" "/opt/Oracle_Java/bin/javaws" 1
  5. Configure the alternative installation
    sudo update-alternatives --set "java" "/opt/Oracle_Java/bin/java"
    sudo update-alternatives --set "javaws" "/opt/Oracle_Java/bin/javaws"
  6. Check installation
    java -version
    java version "1.8.0_211"
    Java (TM) SE Runtime Environment (build 1.8.0_211-b12)
    Java HotSpot(TM) 64-Bit Server VM (build 25.211-b12, mixed mode)

As summary I have a running system with these components:

  • Ubuntu 16.04.2 LTS
  • Mosquitto 1.6.3
  • Oracle JRE 8 (1.8.0_211)

 

@Thomas_Buchner: Which software versions are you using on your system?

 

Re: Open Edge Device Kit (OEDK) Status Messages

Siemens Experimenter Siemens Experimenter
Siemens Experimenter

I am using CentOS 7 64bit:
Operating System: CentOS Linux 7 (Core)
CPE OS Name: cpe:/o:centos:centos:7
Kernel: Linux 3.10.0-957.12.2.el7.x86_64
Architecture: x86-64

openjdk version "1.8.0_212"
OpenJDK Runtime Environment (build 1.8.0_212-b04)
OpenJDK 64-Bit Server VM (build 25.212-b04, mixed mode)

 

I am using mosquitto version 1.5.8