Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Hello, 

I tried to deploy the Mendix App "MindSphere Starter Application" to MindSphere as described here https://developer.mindsphere.io/howto/howto-app-mendix.html.

When I open the app locally, I can see my test-app (see locally.png)

When I open the app in Mindsphere, I only get a white page (see Mindsphere.png). 

I deployed the app to Cloud Foundry, configured the app in MindSphere (see Application details.png) and used "/**" as endpoint, I configured the App Roles & Scopes, registered the app and assigned the app roles. Has anyone an idea, why I can't see my app in MindShpere?

8 REPLIES 8

Re: Problems with the Mendix App: MindSphere Starter Application

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor
Could you please press F12 (devtools) in browser and provide details as to what is the error from Mindsphere launchpad

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

see attachment

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Re: Problems with the Mendix App: MindSphere Starter Application

Siemens Valued Contributor Siemens Valued Contributor
Siemens Valued Contributor

You need to set content security policy so that Mendix widgets gets loaded correctly. Please follow the steps as mentioned below (https://developer.mindsphere.io/howto/howto-app-mendix.html)

 

Set the following content security policy to ensure that the MindSphere OS Bar and the Mendix Feedback widget are loaded correctly:

  • for Region Europe 1 (AWS) use:
    1
    default-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io sprintr.home.mendix.com; font-src 'self' static.eu1.mindsphere.io fonts.gstatic.com; style-src * 'unsafe-inline'; script-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io sprintr.home.mendix.com; img-src * data:;
    
  • for Region Europe 2 (Azure) use:
    1
    default-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io spri

 

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Hi,

 

first idea is that you have not set the content security policies. As described in the documentation they should be

 

for eu1 (AWS)

default-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io sprintr.home.mendix.com; font-src 'self' static.eu1.mindsphere.io fonts.gstatic.com; style-src * 'unsafe-inline'; script-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io sprintr.home.mendix.com; img-src * data:;

for eu2 (Azure) 

default-src 'self' 'unsafe-inline' 'unsafe-eval' static.eu1.mindsphere.io sprintr.home.mendix.com; img-src 'self' static.eu1.mindsphere.io sprintr.home.mendix.com data: uistorageaccountprod.blob.core.windows.net; font-src 'self' data: *.eu2.mindsphere.io uistorageaccountprod.blob.core.windows.net static.eu1.mindsphere.io; style-src 'self' 'unsafe-inline' *.eu2.mindsphere.io uistorageaccountprod.blob.core.windows.net static.eu1.mindsphere.io sprintr.home.mendix.com home.mendix.com; script-src 'self' 'unsafe-inline' 'unsafe-eval' *.eu2.mindsphere.io uistorageaccountprod.blob.core.windows.net static.eu1.mindsphere.io sprintr.home.mendix.com home.mendix.com; connect-src 'self' 'unsafe-inline' *;

 Please try this out, if this is not helping, please open your developer console (F12) and open the network tab when loading the application, also the console tab could give some more hints.

 

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Hi VaibhavV and Stefan4,

 

thanks for your ideas. But it still doesn't work.

I created a new deploymend package in mendix modeler 7.23.4 and pushed it via cf to Mindsphere. During pushing I got the error: "

Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
   fatal: not a git repository (or any parent up to mount point /tmp/buildpacks)

"

List of buildpacks:

buildpack               position   enabled   locked   filename                                       stack
dotnet_core_buildpack   1          true      false    dotnet-core_buildpack-cflinuxfs3-v2.2.11.zip   cflinuxfs3
go_buildpack            2          true      false    go_buildpack-cflinuxfs3-v1.8.39.zip            cflinuxfs3
java_buildpack          3          true      false    java-buildpack-cflinuxfs3-v4.19.zip            cflinuxfs3
nodejs_buildpack        4          true      false    nodejs_buildpack-cflinuxfs3-v1.6.49.zip        cflinuxfs3
php_buildpack           5          true      false    php_buildpack-cflinuxfs3-v4.3.76.zip           cflinuxfs3
python_buildpack        6          true      false    python_buildpack-cflinuxfs3-v1.6.32.zip        cflinuxfs3
ruby_buildpack          7          true      false    ruby_buildpack-cflinuxfs3-v1.7.38.zip          cflinuxfs3
staticfile_buildpack    8          true      false    staticfile_buildpack-cflinuxfs3-v1.4.42.zip    cflinuxfs3
mendix_buildpack        9          true      false    mendix-buildpack-cflinuxfs3-v3.2.1.zip         cflinuxfs3

 

When I open my app, I have a new error: permission denied (see app.png). The given CockpitApplicationName in Mendix is "mendixapp" (see cockpit_app_name.png).

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Hi,

 

Have you build your deployment package from a versioned code base? If yes I guess you have not commited your changes to the team server first.

 

Please commit your changes first or build a package based on the local code base by selecting 'No' in the 'Create Deployment Package' dialog.

 

 

Re: Problems with the Mendix App: MindSphere Starter Application

Experimenter
Experimenter

Thank you very much!