Cancel
Showing results for 
Search instead for 
Did you mean: 

4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator

hi Guys,

 

I am new in post building and i was trying to make 4th axis post.

 

I tried to post but code dsn't post properly

 

 

N0060 T1 M06

N0070 M00

N0080 G90 G00 X-.75 A0.0

N0090 G43 Z8. H01

N0100 S3000 M03

N0110 M08

N0120 G98 G81 X-.75 Y0.0 Z4.425 F10. R4.575

N0130 G80

N0140 G00 A1.8

N0150 A3.6

N0160 A5.4

N0170 A7.2

N0180 A9.

N0190 A10.8

N0200 A12.6

N0210 A14.4

N0220 A16.2

N0230 A18.

N0240 A19.8

N0250 A21.6

N0260 A23.4

N0270 A25.2

N0280 A27.

N0290 A28.8

N0300 A30.6

N0310 A32.4

N0320 A34.2

N0330 A36.

N0340 A37.8

N0350 A39.6

N0360 A41.4

N0370 A43.2

N0380 A45.

N0390 A46.8

N0400 A48.6

N0410 A50.4

N0420 A52.2

N0430 A54.

N0440 A55.8

N0450 A57.6

N0460 A59.4

N0470 A61.2

N0480 A63.

N0490 A64.8

N0500 A66.6

N0510 A68.4

N0520 A70.2

N0530 A72.

N0540 A73.8

N0550 A75.6

N0560 A77.4

N0570 A79.2

N0580 A81.

N0590 A82.8

N0600 A84.6

N0610 A86.4

N0620 A88.2

N0630 A90.

N0640 G98 G81 X-.75 Y0.0 Z4.425 R4.575

N0650 G80

N0660 G00 A91.8

N0670 A93.6

N0680 A95.4

N0690 A97.2

.

in stead of having A90 i am getting this rotation values in 5% increments.

 

pls post the solution if any one has....

 

 

thank you guyzzz

.

.

.

.

 

10 REPLIES 10

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

There is a custom command that comes with PB     pb_cmd_combine_rotary.tcl

add this and follow the included instructions.  This should eliminat the excessive rotary moves.

John Joyce, Manufacturing Engineer,
Senior Aerospace

NX 11.0.2.7 Vericut 8.0.3 - Statements and opinions are mine alone and do not reflect
the opinion of my employer or any other member of the human race

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator

i followed the step 1 , 2 , 3  but didn't work

 

is there any thing wrong the way i added in custom command?

 

please find the attaced file

 

thank you

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

 

Did you put the custom command PB_CMD_combine_rotary_output at the start of the Linear Move ?

Did you put the custom command PB_CMD_combine_rotary_init at the start of program?

 

All of thes steps must be in place for this to work.

 

 

John Joyce, Manufacturing Engineer,
Senior Aerospace

NX 11.0.2.7 Vericut 8.0.3 - Statements and opinions are mine alone and do not reflect
the opinion of my employer or any other member of the human race

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator
yes I did that portion

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Phenom
Phenom

Can you show us your "initial" and "first move" on the "program" tab?

Glenn Balon
Production: NX 12.0.2 MP10 Primarily CAM

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator

please find attachments

 

thank you

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator

my intial anf first move are empty

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

PLM World Member Phenom PLM World Member Phenom
PLM World Member Phenom

Looking at your initial post the moves you show are all rapid motion G00.  You will need to place the PB_CMD_combine_rotary_output custom command at the start of the Rapid Move event as well as the Liner Move event. 

John Joyce, Manufacturing Engineer,
Senior Aerospace

NX 11.0.2.7 Vericut 8.0.3 - Statements and opinions are mine alone and do not reflect
the opinion of my employer or any other member of the human race

Re: 4TH AXIS POST ISSUES - A axis rotation are not properly posting...

Creator
Creator

dsn't work

Learn online





Solution Information