Cancel
Showing results for 
Search instead for 
Did you mean: 

Browse for unmanaged templates working with Teamcenter

Creator
Creator

 

 

Hello,

 

I have a problem with browsing for template parts, using Teamcenter

 

All my operation templates are on the native file system.

Until NX9, there was no problem to get a particular part as a template part from outside Teamcenter.

Now in NX12 I can only get parts managed with Teamcenter. Are there any preferences to define the acces to the file system?

 

 

2019-04-04_16-52-43.jpg

 

2019-04-04_17-02-47.jpg

 

NX9:

2019-04-04_16-57-43.jpg

 

NX12:

2019-04-04_14-24-00.jpg

 

 

The same Problem exists when I want to initialise a machine if I'm using LIBRARAY_SETUPS.

These are not in Teamcenter, but NX search in TC.

2019-04-04_16-48-28.jpg

 

 

Thanks for any suggestions.

 

 

 

 

4 REPLIES 4

Re: Browse for unmanaged templates working with Teamcenter

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

How are you setting up your CAM configuration?

E.g. open a new part with no CAM info

Application -> Manufacturing

You get a dialog - what do you select there?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Re: Browse for unmanaged templates working with Teamcenter

Creator
Creator

Hello Ken_A,

 

Yes, I start with a new part, Application, Manufacturing. "Delete Setup" works as the same.

 

You have to know, some of my Configurations are defined with Library_Setups. I don't really want towork with Lybrary Setups Parts or Part Planner.
The reason is,  we need this two variables setted in  the configuratoin file (*.dat):

LYBRARY_CAM_OUTPUT

LYBRARY_SETUP_TEMPLATE

 

Thats needed to import some files generated in Manufacturing (e.g. NC-Files, CLS-Files, xml created by post) to Teamcenter.

At saving, this window appears:

2019-04-05_09-01-05.jpg

 

In my opinion the LYBRARY_CAM_OUTPUT should do that by onself, but it works only if the LYBRARY_SETUP_TEMPLATE  is set too.

If the LYBRARY_SETUP_TEMPLATE is set, then you have to define the templates not in the ...custom\template_set\*.opt, they have to be defined in ...custom\template_dir\*.def!

 

 

 

 

Now back to how I do Initializing.

 

Initializing a configuration without Library Setups, works native and with Teamcenter:

2019-04-05_08-49-30.jpg

OK, and it's done.

 

 

 

Initializing a configuration with Library Setups.:

Step 1) There you cant select a Setup Part. Press OK.

2019-04-05_08-47-44.jpg

 

Step 2) Select the machine from the Lybrary. OK.

2019-04-05_08-30-18.jpg

 

Step 3) Select the Setup Part:

2019-04-05_08-31-02.jpg

Now it's done.

 

This worked until NX9 with and without Teamcenter as well.

In NX12 it works native only.

 

With NX12 and Teamcenter, after Step 1 appears this Window:

2019-04-04_16-48-28.jpg

 

I think, NX is searching for the files in Teamcenter instead on the native file system (...custom\setup_dir\...).

Also it can be the sam problem as "Browse for Templates".  

 

 

 

Regards

TomS

 

Re: Browse for unmanaged templates working with Teamcenter

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

From my experience template parts always needed to be imported into Teamcenter, since we started using it in 2008.

We skipped NX 9, but importing was mandatory in NX 8.5 and NX 10 for us.

Generally anything that is a NX part file needs to be imported into Teamcenter.

We are also maintaining two environments one for native and one for managed NX. There are only a few things that can be shared between them, but template parts or not one of them.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.2, FBM, MRL 3.1.7 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 11.4
Development: C (ITK), .NET, Tcl/Tk Testing: NX12.0 | AWC 3.4 Preparing: NX12.0

Employees of the customers, together we are strong Smiley Wink
How to Get the Most from Your Signature in the Community
NX Customization - Best Practice Guide

Re: Browse for unmanaged templates working with Teamcenter

Gears Esteemed Contributor Gears Esteemed Contributor
Gears Esteemed Contributor

I believe the issue is the library setups.

We use configurations [the equivalent of] cam_general.dat

We can use either op templates stored in either native or TC, pointed to by the appropriate template set (.opt) file.  (although you can't really mix them in one OPT file, IIRC).

 

I have moved most of the op templates into Teamcenter, so all my OPT files point to TC parts.

 

I would suggest you move yours into TC - is there a reason (other than the drudgery of moving them) preventing you from doing this?

Note there is a .BAT to import the "as installed" files into TC, if you want them as well.

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP16/TC11.2
I'd rather be e-steamed than e-diseaseled


Learn online





Solution Information