Cancel
Showing results for 
Search instead for 
Did you mean: 

CFI_delete_file

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hi, 

 

I have an unknown error for me. I usually use a function for rename the post output file. 

 

The function worked perfectly on the NX10, but now the customer has switched to the NX11 and the function has stopped working. 

 

The output file disappears after the post-processing. And I find it among temporary files.

 

I attach the customer syslog file and the rename_file proc. 

 

Does anybody know what is happening?

 

Best Regards

Ivan

5 REPLIES

Re: CFI_delete_file

Phenom
Phenom

I copy your proc to CMD and adjust a little.

I put CMD in the program end sequence.

It works in my NX11

 

CMD:

-----------------

global mom_post_in_simulation
    global mom_output_file_directory mom_output_file_full_name
    global mom_group_name mom_operation_name

        MOM_close_output_file $mom_output_file_full_name
        if {[info exists mom_group_name]} {
            set programa "1234"
        } else {
            set programa "1234"
        }
        set extension ".h"
        set new_file $mom_output_file_directory$programa$extension
        file rename -force $mom_output_file_full_name $new_file

-------------------

---------------------------------------------
#♫ PB, 5ax, itnc, nx, vericut ♫ #

Re: CFI_delete_file

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hi, 

 

Yes I know, it works also on my computer but not on the customer´s and I don´t know what may be happening.

 

Why does it work on NX10 and not on NX11? Are there any options I do not know?

 

best Regards

Ivan

Re: CFI_delete_file

Phenom
Phenom

hm,

I have  one customer that has this issues in NX11 (they are also logged):

 

1.generating in the backround takes infinite time

2. generating IPW takes infinite time

-- he reinstal NX and repair the instalation path - delete space and dots and he told me 1,2 issue is fixed.

But gtac doesnt think this was the cause of these two problems.

3.changing stock doesnt make operation inactual (after restarting NX  functionallity is back)

---------------------------------------------
#♫ PB, 5ax, itnc, nx, vericut ♫ #

Re: CFI_delete_file

Esteemed Contributor
Esteemed Contributor

This bothers me (from syslog):

CAM_FILE: received CFI error -1 from CFI_delete_file(C:\Users\juaniko\AppData\Local\Temp\juan2044FB2A7cui)

 

I would use "MOM_output_to_listing_device" to output all the variables used to the Info window

Compare to what user entered in postprocess dialog (you may need to do something as path of output file in dialog is real long)

Compare the 2

You may want to use the tcl command "file exists" to see if the file exists before renaming it?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: CFI_delete_file

Esteemed Contributor
Esteemed Contributor

Are you both on the EXACT same version of NX 11?

Syslog shows "NX 11.0.1.11 MP2"

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Learn online





Solution Information