Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

CSE - spindle component rotation - NX10.03. MP13

Hello everybody,

 

I noticed something strange with using a spindle component as a _DEVICE.

 

We dont get a rotary body while setting a spindle speed and direction. Is it correct?

In contrast to a lathe machine, a rotary body is produced.

 

Best wishes from Hamburg

Viktor

 

13 REPLIES

Re: CSE - spindle component rotation - NX10.03. MP13

Hello,

 

please check the CD setting (should be on). That might solve it. If not we may have to analyze further.

 

Thomas

 

2017-04-28 10_49_44-Customer Defaults.png

 

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: CSE - spindle component rotation - NX10.03. MP13

Hi,

 

thank you for the quick reply.

I checked the option, it is on.

Re: CSE - spindle component rotation - NX10.03. MP13

Hello,

 

do you have a chance to test it in NX11.0.1? From my view that should work.

 

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: CSE - spindle component rotation - NX10.03. MP13

Hi,

 

I tested it with NX 10.01. and the result is the same.

There is no rotary body with spindle speed and spindle direction.

 

A workaround could be a spindle component as a device that I choose in a CAM Setup.

 

Best wishes
Viktor 

Re: CSE - spindle component rotation - NX10.03. MP13

I do not have any further idea, I assume you do have an axis created inside the KIM representing the spindle

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software
Solution
Solution
Accepted by topic author VikP
‎05-03-2017 05:12 AM

Re: CSE - spindle component rotation - NX10.03. MP13

[ Edited ]

I solved the problem with using a lathe spindle and the spindle component as a static holder.

Now it looks very good.

2017-05-03_10-58-36.png

 

Best wishes

Viktor

Re: CSE - spindle component rotation - NX10.03. MP13

And the story goes on...

 

Hi everybody,

 

now we use a head with a v-axis and a pocket mounted tool :

 

2017-06-16 07_52_02-ConmatiX - NX CAM 10 DEVOPS Presales Environment Weir Minerals - Fertigung - [11.png

 

Everything is mounted and here is the situation on the right position of cutting operation (Sxxx M3) :

 

2017-06-16 07_56_00-ConmatiX - NX CAM 10 DEVOPS Presales Environment Weir Minerals - Fertigung - [11.png

 

Great, right? Smiley Happy

 

The current workaround is the following NC code after the head/tool change:

    G0 Y1450 (= CSE starting position) M5

    M0
    S200 M3
    m5

 

Do someone know an issue like this?

 

Regards, Viktor

 

Re: CSE - spindle component rotation - NX10.03. MP13

[ Edited ]

Hi VikP,

 

do you have created the head as a device classified as HEAD?

 

Thomas

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: CSE - spindle component rotation - NX10.03. MP13

Do you mean the ascii entry?

 

DATA |M325_FACINGHEAD | 3 |M325_FACINGHEAD| HEAD

 

I dont have a static holder for the head. I get the head from a dynamic holder. 

Is that a problem?

Learn online





Solution Information