Cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

CSE wrong Z vector direction on SUB spindle

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

Hello

I have a problem with dual channel millturn machine. The first channel simulation works properly, but the second channel has a wrong direction of Z Axisin simulation. Postprocesor works good, the value is good but only the simulation in bad.

 

My question, how to change the direction of vector Z in CSE? Where I should do this?

 

wrong direction.PNG

4 REPLIES 4

Re: CSE wrong Z vector direction on SUB spindle

Siemens Phenom Siemens Phenom
Siemens Phenom

Hello here some hint to find a solution.

 

I would nail it down to simple NC code, to identify where the problem is.

Moving to X0 Y0 Z0 with / without offset like G43

Moving to X0 Y0 Z0 with / without tool length compensation D1 / G43 H1

 

If the problem is related to the tool length compensation, what is my guess, you first can check if the data which is used for correction is valid; doing this by enter into the variable section getLCorrection() getQCorrection() getZCorrection()

 

Then often the method which is doing the mapping between these values and the machine axis need to be adjusted.

the method can be found in the Machine Configurator and is called

GMe_ActivateToolCorrection or GMe_SetToolLengthCorrection you may can have a look into sim15 where the correction is implemented differently for milling/turning and for different channels.

 

Here you also find a useful video about that topic.

https://community.plm.automation.siemens.com/t5/Tech-Tips-Knowledge-Base-NX-Manufacturing/CSE-Simula...

 

Check video number 04 or 10

 

 

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: CSE wrong Z vector direction on SUB spindle

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

 Hi,

I based on the sim15 and I try to create millturn dualchannel witch only one postprocessor. I check the tool correction and it is works properly. I think, that the SUB spindle use the Z Axis vector from MAIN spindle, which is incorrect, it must be in other side. When I checked everything step by step in the simulation, I saw, that SUB spindle has a Z axis on the same direction as in main spindle. Postprocesor works good, only simulation can not change Z axis. 

 

Can you have any idea how to solve the problem? 

 

Re: CSE wrong Z vector direction on SUB spindle

Siemens Phenom Siemens Phenom
Siemens Phenom

Sorry, but I didn't got that in detail.

The Z axis is part of the head and not by the main or subspindle.

 

Can you post figures and more detail for better understanding please if possible.

 

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: CSE wrong Z vector direction on SUB spindle

Solution Partner Pioneer Solution Partner Pioneer
Solution Partner Pioneer

When I set MCS witch fixture offset 2 on SUB base MCS, the simulation is ok. 

 

22.PNG

 

When I set this MCS on the face of workpiece, the simulation is mirrored about SUB base MCS. 

 

11.PNG

 

The same situation has place, when I set MCS deep into spindle, mirrored situation like previous one. 


33.PNG

 

 

I think, that is cause vector Z direction 

 

Learn online





Solution Information