Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Circular interpolation error in simulation

Hello everybody,

during the simulation of a part program i get the following error

To exclude any error on the virtual machine I used the out-of-the-box NX10 sim01_mill_3ax metric machine with fanuc controller.

The part program run on the real machine without any error.

The real machine has a fanuc controller.

I was wondering if the problem is related to parameter 3410. The value of this parameter on the real machine is 0.5.

It seems that the value of 3410 on the virtual machine defaults to 0 (this should mean the simulation should not check at all for circular interpolation error)

I have tried to set the parameter on the virtual machine with the same value of the real one, or much more higher,  but the problem still exists.

Does anybody know how to set circular interpolation tolerance on the virtual machine to obtain the same behaviour of the real one?

thank you

best regards

2 REPLIES
Solution
Solution
Accepted by topic author cospaSimulation
‎02-11-2016 09:49 AM

Re: Circular interpolation error in simulation

To trigger the tolerance you can influence it by changing the setting of precision used for motion planning. You will find that setting in the Machine Configurator -> General tab called "Motion Precision". Try to change this to avoid such messages.

 

Thomas Schulz
Siemens PLM
Manufacturing Engineering Software

Re: Circular interpolation error in simulation

I raised the precision to 0.03 and the error is gone.

Do you know if parameter 3410 is completely ignored?

Best Regards, thank you very much

Learn online





Solution Information