cancel
Showing results for 
Search instead for 
Did you mean: 

Curious NX10/PB issue with Tool Call CMD

Creator
Creator

Hi There !

 

i have a strange issue with PB10.0.2/NX10.0.2 on heidenhain itnc530

 

Within the tool call definition, i also define the feed rate. The output should be the following:

 

TOOL CALL 4 Z S12500 F4000 DL+0 DR-3

 

The Block CMD definition looks like this:

BLOCK_TEMPLATE tool_change_new
  {
       Text[TOOL CALL]
       Text[$mom_tool_number]
       Text[Z]
       S[$mom_spindle_speed]
       F[$mom_feed_cut_value]
       Diff_length[+0.]
       Diff_radius[-\$mom_tool_diameter/2]
  }

The curios thing is, that everytime when i save the post file, the spindle and feed rate switches. When i open the .def file i can correct the entry but everytime when i open the post in builder the same happens again.

 

Because of the HH syntax, the spindle rate has to be declared before the feed rate.

 

Does anyone know where this issue comes from ?

 

Thanks in advance

Wolfgang

 

Here a pic of the Block CMD in PostBuilder.b1.jpg

 

NX 10.0.2
PB 10.0.2
Win7 64
2 REPLIES

Re: Curious NX10/PB issue with Tool Call CMD

Valued Contributor
Valued Contributor
Did you change the order in "word sequencing"? I think the default is F before S.
W10 NX11.0.1

Re: Curious NX10/PB issue with Tool Call CMD

Creator
Creator

Yeah, thanks, that was the "problem".

 

No its working.

 

regards

wolfgang

NX 10.0.2
PB 10.0.2
Win7 64

Learn online





Solution Information