cancel
Showing results for 
Search instead for 
Did you mean: 

Cutcom settings for Millplus

Experimenter
Experimenter

Dear all,

 

I want to build a PP for a DMU 70EVO with Millplus and I need help with cutcom in the Postbuilder.

 

The problem is that the Millplus control needs G43 (Radius compensation to end point) and G41/G42(Activate radius compensation to the right )

I tried to solve it like this:

 

global mom_cutcom_status

if {$mom_cutcom_status=="LEFT" || $mom_cutcom_status=="RIGHT"} {
MOM_do_template G43
}

 

but the output is like this:

N0220 X-5.434 Y-16.462 Z10.
N0230 Z-12.5
N0240 G94
N0250 G01 Z-15.5 F250.
N0260 G43 X0.0 Y-14.
N0270 G41
N0280 G43 Y-5.
N0290 G41
N0300 G43 Y120.
N0310 G41
N0320 G43 X120.
N0330 G41
N0340 G43 Y0.0
N0350 G41
N0360 G43 X0.0

 

How can I set the G43 only once before the G41

Thanks for the help.

 

millplus.jpg

2 REPLIES

Re: Cutcom settings for Millplus

Esteemed Contributor
Esteemed Contributor

First try:

1) Make sure the "G43" word is modal

2) Make sure you add a "MOM_force once (whatever the G43 word's name is)" is in "start of path" (there should be proc that forces words in "start of path" event)

2A) you might also want to do a "MOM_force once (whatever the G43 word's name is)" in cutcom off event?

 

Looks like a similar issue with G41

 

 

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Cutcom settings for Millplus

Experimenter
Experimenter

Thanks for your your help!

The problem was my block definition.

I use a user G_cutcom and so he switchted between G41 and G43 now I changed it in a user defined and now it works.

Learn online





Solution Information