Cancel
Showing results for 
Search instead for 
Did you mean: 

Cutter comp cancel on hole milling

Legend
Legend

It seems no matter what combination of "minimum clearance" or "minimum move" in cutter comp I use, the cutter comp always cancels at the end of the retract, which causes our control to alarm out. I have been using the old cutter compensation UDE as a workaround, but there must be a better way. Has anyone else had to deal with this?

 

I just want the G40 cutter comp cancel to be where I put the red dot in the pic shown below. 

 

 

 

cutter comp issue.PNG

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM
14 REPLIES

Re: Cutter comp cancel on hole milling

Gears Phenom Gears Phenom
Gears Phenom

I think it also depends where G40 is.

- on separate line - after or before retract

- or outputed as event -also in separate line

-or in line with move

 

I prefer G cutcom in line with move.(I removed everything from cutcom "off" and "on" event)

I you want you can then move Gcutcom in linear move/circular move above or bellow block.

 

 

minimum clearence and minimum move - I think this tells nothing about where is cutcom turned on/off.

It is about move length.

 

---------------------------------------------
#♫ PB, 5ax, itnc, nx, vericut ♫ #

Re: Cutter comp cancel on hole milling

Legend
Legend

Thanks,

 

Below is how I have my post set up. There is only a force once D command on the "Machine Control" That is not related I do not believe. 

 

Is this what you were describing?

 

cutcom issue pic3.PNG

 

 

cutcom issue pic2.PNG

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: Cutter comp cancel on hole milling

Legend
Legend

The small orange X shows where the cutcom off is in the clsf when you select "replay"

 

It is being output, just not where I want it. Maybe I can add the G40 to the rapid event in its own line before the G0 move?

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: Cutter comp cancel on hole milling

Gears Phenom Gears Phenom
Gears Phenom

I supose G40 is in retract - this is not good?,

because till now Ive never seen such problem (fortunately)

 

In the end of this move tool should be on center.

Not sooner. By move is executed - to not damage the cylinder surface.

 

(You can pull G_cutcom bellow or above in the move if you want.)

(You can also add Gcutcom to rapid move /in line, bellow,above/. But I would leave modal 40/41/42, not hardoced 40 or somethhing)

 

I hope there is nothing special pp edit to have working nc code.

---------------------------------------------
#♫ PB, 5ax, itnc, nx, vericut ♫ #

Re: Cutter comp cancel on hole milling

Siemens Phenom Siemens Phenom
Siemens Phenom

Hi TechniCsNC

Is it because the retract is at rapid with cutcomp still active? If so programming the retract at the fastest machine feedrate may quickly overcome this isse and be safe as to not cancel the cutcomp near the wall potentially causing a touch.

This is probably what I would do as you don't get to visualize cutcomp on/off with Machine/GCode simulation.

Regards

Paul 

Re: Cutter comp cancel on hole milling

Genius
Genius

I have my comp on/off on the linear motion line. I get what you want.

The force at comp off just makes the Dvalue appear everytime the comp code comes out.

 

But to get this to work right. I have to go into non cutting moves and set my engage and retract to "none"

Then set my "more tab" "cutter compensation" to the approach move I want at a 90 deg. angle

Works for all finishing 

 

It's the only way I can get the comp the way we want it for circle milling. Used it on many different machines over several versions. Changed my template file settings so it always comes in set to work.

 

** You are seeing the alarm because of the non-cutting move. It always starts at the center and there is no way to get the minium move... so it forces the comp code out like it says. which is after the linear move.

 

 

Capture.JPGCapture2.JPGCapture3.JPG

 

{Paul Schneider}, {CNC Programmer}, {DRT-Rochester}


Production: {NX11.0.2,MP5, NX12.0.1, MP2}

Re: Cutter comp cancel on hole milling

Legend
Legend

Thanks,

 

Looks good now. It is a shame that the start from center doesn't work with cutter comp. Sure I can tweak the engage move, but it is an extra step/calcauation based on tool dia and diameter of hole I am cutting. I can pick a few different numbers and just eyball it in like I usually do though. 

 

Thanks again for the solution. I knew someone must have found a way to deal with this. 

 

 

updated engage.PNGupdated engage2.PNG

Glenn Balon
Production: NX 12.0.2 MP3 Primarily CAM

Re: Cutter comp cancel on hole milling

Genius
Genius

I'm glad we can tornado mill with cutter comp. it's a favovite move of mine.

 

The only down side I have found and submitted an IR, converted to a PR #8982266 is...

 

Being that this is the only way to make the comp come out in the correct spots. If you chose to do mutiple radial passes. Say rough, rough and finish it will not work. it goes from the bottom of the first cut directly to the top of the next (there is material in between)

** The fix is easy. they just need to make the tool come up in Z then move over... Who knows when this will happen

 

The work around is make your rough and finish passes seperate processes. No comp on rough and use non-cutting moves. Finish pass as described above.

 

(I wouldn't worry about getting back to the center, your .005 move is off the wall and safe to come out)

 

Happy Milling!!

 

{Paul Schneider}, {CNC Programmer}, {DRT-Rochester}


Production: {NX11.0.2,MP5, NX12.0.1, MP2}

Re: Cutter comp cancel on hole milling

Valued Contributor
Valued Contributor

Screenshot.png

 

 If you set the engage type to circular you should get the tool to start at the center and use cutter comp.

Hth Eric

Learn online





Solution Information