Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Edit Machining Data Libraries

Hi there,

 

I am pretty new in NX and I have a problem with the Edit Machining Data Library.

I've created a Library and I can choose the Data in Workpiece and Material,but I can't choose the method.It just don't come up.

See sreenshots for that.I created Test.

If anyone got any help with that would help me a lot.

 

It seems to be a programming prolem because it's saved correctly.

30 REPLIES

Re: Edit Machining Data Libraries

Can you show your machining methods tab too?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: Edit Machining Data Libraries

Machining Tabs are just Standard.

I'm on a Try and Buy Version. NX9.

Re: Edit Machining Data Libraries

you need to add the methods in your resource folder.

Re: Edit Machining Data Libraries


kamax-sk wrote:

Machining Tabs are just Standard.

I'm on a Try and Buy Version. NX9.


I thought about posting a screen shot of the "Bearbeitungsmethoden" tab.

 

BTW, have you reloaded the CAM configuration through "Preferences => Manufacturing => Configuration" and press both reload buttons, if you are testing in a different session than the one you change the settings?

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: Edit Machining Data Libraries

The cut methods you show are not out of the box, so I am not sure what you have done.

 

You should see these:

OPD0_00001|LATHE|TURN, POINT|0
OPD0_00002|DRILL|BORING|0
OPD0_00003|LATHE|TURN, CUTOFF|0
OPD0_00006|MILL|FACE MILLING|0
OPD0_00007|MILL|END MILLING|0
OPD0_00008|MILL|SLOTTING|0
OPD0_00010|MILL|SIDE/SLOT MILL|0
OPD0_00011|DRILL|DRILLING|0
OPD0_00021|MILL|HSM ROUGH MILLING|HSM - With Proven Machining Data
OPD0_00022|MILL|HSM SEMI FINISH MILLING|HSM - With Proven Machining Data
OPD0_00023|MILL|HSM FINISH MILLING|HSM - With Proven Machining Data

 

 

.

Mark Rief
Retired Siemens

Re: Edit Machining Data Libraries

[ Edited ]

@markriefthis is exactly what it says except for the one I generated.

 

The issue that have isn't to generate a library.It's that I can't use it as a method,when I generate a new operation.The new library won't show as a cutting method.

 

 

Re: Edit Machining Data Libraries

I also have a problem with changing a methods.

If I change a method,let's say OPD0_0001_LATHE_TURN,POINT and rename it or just open and save it,it won't appear in the drop-down menu any more.

Watch sreenshots

Re: Edit Machining Data Libraries

Could you widen the column of the library reference, so that the whole libref of the "Bearbeitungsmethode" is shown?

 

Are you setting up CAM on your own or is someone experienced helping you?

Without any help it is usually hard to find the right way to set up CAM.

 

Where do you save the feeds and speeds files?

If you save it to the installation folder of NX, which is the default, you won't be able to save them, since Windows is preventing this, which should not be changed.

 

If you have copied the entire MACH\resource folder over to a location where you have write access, there should be no problem.

I would really advice you to create a copy of the resource folder, so you have full access and don't have to change any Windows security measures.

You only have to change the environment variable UGII_CAM_RESOURCE_DIR to point to the copied folder to use that.

 

To verify that your changes get saved, you can check the ANSI text file at "%UGII_BASE_DIR%\MACH\resource\library\feeds_speeds\ascii\cut_methods.dat" or the one in the copy of the resource folder if you have one.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Re: Edit Machining Data Libraries


kamax-sk wrote:
let's say OPD0_0001_LATHE_TURN,POINT and rename it

The problem is the comma in the library reference, which is not allowed.

To overcome this problem use a dash instead, since the comma is the field separator in the data file.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX11.0 EAP, NX12.0 EAP

How to Get the Most from Your Signature in the Community

Learn online





Solution Information