Cancel
Showing results for 
Search instead for 
Did you mean: 

Re: Engage and Transfer Smoothing

Valued Contributor
Valued Contributor
yes,it's funny that you can tell its a Fanuc 0i.

Re: Engage and Transfer Smoothing

Siemens Phenom Siemens Phenom
Siemens Phenom

Juraj is correct in his statement about the smoothed motions being splines, and therefore we cannot output them as circular motions for the machines.

 

As for your slow transfer motion problem, I am glad to say that we have a solution for this. The requirements driving this project made for the option to turn the smoothing on or off for the rapid motions. As one customer told us, some machines can't handle such smoothing on their transfers because they shake so badly they would rumble the building. Other machines don't have such problems. So to address this issue we have made smoothing transfer motions optional in an upcoming version with a toggle switch in the same group of the Smoothing tab. When you select the Smooth Corners toggle, another pops up with the rest of the parameters allowing you to smooth all engage and retract motions, but have the option to leave the transfers unsmoothed. 

Re: Engage and Transfer Smoothing

Siemens Phenom Siemens Phenom
Siemens Phenom

By the way, there may be some confusion as to which smoothing option you are refering to. Are you speaking of "Override with Smooth Connections" in operations like Contour Area and Variable Contour? Or are you speaking about "Smooth Corners" which has been added to many of the planar type operations such as Cavity Mill, Floor Wall and Planar Mill?

Re: Engage and Transfer Smoothing

Valued Contributor
Valued Contributor
It was the new Smooth Corners that was recently added to the planar type operations. I haven't been machining much as of late but the "fix" I came up with was in the feeds and speed dialog box, I changed the "approach" and "departure" feeds from rapid to a high feedrate that all my machines can handle. I left the traversal rate to rapid. This made everything smooth. The issue is definitely is machine side. It tries to rapid between the little line segments that make up the "smoothing arc" and its very rigid about it. For whatever reason it is smooth when using feed rate rather than a G00.

Re: Engage and Transfer Smoothing

It is smooth because the G1 moves are being interpolated. Another option is to change the Rapid output mode from G0 to G1. Then all of the former G0 moves will be G1.

Mark Rief
Retired Siemens

Learn online





Solution Information