Showing results for 
Search instead for 
Do you mean 
Reply
Solved! Go to solution

Error while post processing

Hi,

 

Please see some lines from log file attached. Error occurs while post processing. The post is working for some files and gives error for some. When checked between the two files - one wher e its working and another where its not working, I did not find any difference. Hence your help is required to understand what the error is and why its coming.

 

The only customization done in the post is creating 'Tool List' at start of program. The code ssems ok as its working on some files.

 

Post is built using NX post builder. It has main post with 1) Positional 2) Simult and 3)Turn post as linked.

 

Thanks in advance.

BR
Mak
TC10/NX 9
6 REPLIES

Re: Error while post processing

"Hidden geometry - Reference sets need to load entire part.; Hidden eid - Reference sets need to load entire part returned when executing command MOM_cycle_objects"

 

Do you have all components fully loaded in your CAM setup?

Marek Pawlus, NCmatic

Production: NX 11.0.1
Development: C#, Tcl/Tk, CSE

Re: Error while post processing

[ Edited ]

Yes Marek_Pawlus.

 

My first doubt was the same so loaded all parts with 'entire part' referance set.

 

Other parts where the post is working, I did not changed the ref sets though.

BR
Mak
TC10/NX 9
Solution
Solution
Accepted by topic author Mak_Jo
‎09-17-2015 08:16 AM

Re: Error while post processing

Problem solved !

 

Issue was with one sub assembly which were not loaded....deleted tha tassembly and it worked. Changed the 'search' path for the same and working now.

 

On question still remains...how hidden geometry or unloaded geometry stops tool path from post processing ?

BR
Mak
TC10/NX 9

Re: Error while post processing

I guess I'm as curious as Mak - Why does the *post* need component geometry?  It should be posting the internal toolpaths, plain & simple.  As long as the CAM part is fully loaded (so the internal toolpaths are available) you should be able to load the CAM part "structure only" and be able to post?

 

Or is this a change to allow CAM to come from components?

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: Error while post processing

Hi Ken,

started separate thread for the question which I asked and you are also curious about.
BR
Mak
TC10/NX 9

Re: Error while post processing

I use cycle_objects in posting and always put a catch around it now. It seems that along the way - errors started to be raised. I think the objects I care about are there regardless of loaded components.

NX10.03
Windows 7 Pro

Learn online





Solution Information