Cancel
Showing results for 
Search instead for 
Did you mean: 

FBM Multi axis error

Builder
Builder

Hello,

 

right know I have an issue with teaching multi axis operation (variable contour).

I have teached feature and created sucessfully the operation variable contour and teached

the operation to the MKE. When I create the operation for verification it works, but when i generate the tool path I geht the following message:

2.JPG

 

And when I try to edit the operation I geht this message:

Unbenannt.JPG

 

Hope you can help. Thank you.

NX 11.0.1.11
5 REPLIES

Re: FBM Multi axis error

Esteemed Contributor
Esteemed Contributor

First thing I would look at is the syslog (Help -> NX log file)

It could have some info as to WHAT variable / attribute is the issue.

 

I've no idea where to go from there, however (I haven't had a chance to play with FBM)

Ken Akerboom Sr CAx Systems Engr, Moog, Inc.
Production: NX10.0.3.5 MP5 + patch/TC11.2
I'd rather be e-steemed than e-diseaseled


Re: FBM Multi axis error

Esteemed Contributor
Esteemed Contributor

Since the operation is not different if created manually or by FBM, because FBM only applies the values that usually a user would do manually through the operation dialog.

I would first do a part cleanup in the gateway application and clean up the CAM objects. Important is to do part cleanup in gateway to reduce the possibility of objects being locked by the application, modeling, drafting, manufacturing, etc.

Check if the problem still exists.

Afterwards I would open the machining knowledge XML in MKE, but using the update function, to make sure the definitions for the values are all up-to-date. You should then check the validity of the entire machining rules and correct any errors, if there are some.

Now you should try again to see if that helped.

By the way, I would advice you to add at least your NX release in your signature (follow the link at the bottom of my signature), so we don't have to always ask for it, because the used NX release can make a huge difference.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: FBM Multi axis error

Builder
Builder

Hello,

 

thank you for that information. How can i do a part cleanup in gateway application ?

 

I have created now a new CAM session and also using the ootb resource folder and then teached the

feature, created the multi axis operation and teached it to the MKE. When I generate the

Operation I still get the same message.

 

I have checked the machining Rule and there are some warnings:

 

 

1.png

 

I have tried to fix the warnings, but at the end I get the same message when I generate the Operation.

Maybe it has something to do with some missing attributes because I have teached the feature...

I have no problems with other teached operations just with multi axis.

 

I have uploaded the machining feature in xml, hope this can help you, to help me Smiley Happy

 

I'm using NX 11.0.1.8

NX 11.0.1.11

Re: FBM Multi axis error

Esteemed Contributor
Esteemed Contributor

I have checked the XML file and fond the following problems:

REM Path Settings -> Cutting Parameters -> Corners -> Feed Slowdown in Corners -> Slowdown Distance
oper.Corner_Control_Slowdown_Length_Method = "?"

REM Drive Method -> Drive Settings -> Tool Position
oper.Tool_Position = "?"

There seems to be a problem that you need to report to GTAC, since teaching an operation should never result in a machining rule that contains invalid settings.

You can correct the machining rule manually be deleting = "?" in both cases, then you enter the equal sign, which in turn will offer you a list of possible values, where you can select the correct one from.

Validate the machining rules again and correct any remaining errors.

Stefan Pendl, Systemmanager CAx, HAIDLMAIR GmbH
Production: NX10.0.3, VERICUT 8.0, FBM, MRL 3.1.4 | TcUA 10.1 MP7 Patch 0 (10.1.7.0) | TcVis 10.1
Development: VB.NET, Tcl/Tk    Testing: NX12.0

How to Get the Most from Your Signature in the Community

Re: FBM Multi axis error

Builder
Builder

The problem of the internal error is determined.

 

it has something to do with oper.Drive_Method in the MKE - not all methods are supported.

By chaning the drive method in oper.Drive_Method = "Boundary" the problem is solved!

NX 11.0.1.11

Learn online





Solution Information